Support » Plugin: WooCommerce Square » Square Certificate Authority invalid when requesting paymentform script

  • Resolved Marlon

    (@marlonlamancio)


    Hey guys, I hope you all are well!

    I’m receiving several feedbacks from customers who are unable to buy on my website https://www.tutuspantry.com/ because of the fields on the card form at checkout are disabled.

    I was unable to reproduce the error here (MacOS, Chrome) but a client running Windows 10 sent me the following Chrome Console log:

    paymentform:1 Failed to load resource: net::ERR_CERT_AUTHORITY_INVALID
    wc-square.min.js:220 Uncaught ReferenceError: SqPaymentForm is not defined
        at n.value (wc-square.min.js:220)
        at HTMLBodyElement.<anonymous> (wc-square.min.js:107)
        at HTMLBodyElement.dispatch (jquery.js?ver=1.12.4-wp:3)
        at HTMLBodyElement.r.handle (jquery.js?ver=1.12.4-wp:3)
        at Object.trigger (jquery.js?ver=1.12.4-wp:3)
        at Object.a.event.trigger (jquery-migrate.min.js?ver=1.4.1:2)
        at HTMLBodyElement.<anonymous> (jquery.js?ver=1.12.4-wp:3)
        at Function.each (jquery.js?ver=1.12.4-wp:2)
        at a.fn.init.each (jquery.js?ver=1.12.4-wp:2)
        at a.fn.init.trigger (jquery.js?ver=1.12.4-wp:3)

    As I understand the problem is in the invalidity of Certificate Authority of Square’s certificate when requesting the file https://js.squareup.com/v2/paymentform and therefore it is not possible to load and find SqPaymentForm object.

    Pretty weird because it seems that the error only happens on machines running Windows 10 and Chrome, both updated with the latest versions and patches.

    As it is not an error “on my side” I am not finding a way to solve it.

    Has anyone had this error or can help me figure it out what’s going on?

    The page I need help with: [log in to see the link]

Viewing 13 replies - 1 through 13 (of 13 total)
  • treydismukes

    (@treydismukes)

    This is a good place to look. The next time I have a customer with this issue I will check the CA they’re being sent.

    bsktbllsam

    (@bsktbllsam)

    I’m having the same issue. I don’t know how to read code, but when you follow that link you sent ( https://js.squareup.com/v2/paymentform ) Theres a bunch of error messages in there.
    “FormNotReadyError”
    “TooManyIdsError”
    “Unknown SqError”))).name=”SqError”

    Actually, the whole thing looks like a giant error message.

    realcurtgranger

    (@realcurtgranger)

    I’ve been experiencing this, both Windows 7 and 10 desktops, with Chrome. I just tested on another desktop running Windows 7, with Chrome Version 83.0.4103.61 (Official Build) (32-bit) – hasn’t been updated in a while, and everything works as it should. I see the pre-populated …. in the CC number field, MM/YY, etc.

    So, the issue is a Chrome update incompatibility with the Square certificate/javascript?

    realcurtgranger

    (@realcurtgranger)

    Marlon I went to https://www.tutuspantry.com/ and tried there – same problem. So I went back to my site that had worked, reloaded it, and now it doesn’t. So, appears not to be Chrome update related, but rather WordPress/Woo Commerce related.

    My website admin is working on this with me, and he’s rolling back to prior Woo and other plugin and theme updates. I’ll post again if we can figure out what’s going on.

    Plugin Support Elvira K

    (@treibalen)

    Hi @marlonlamancio, @treydismukes, @bsktbllsam, and @realcurtgranger,

    Thank you for reporting the issue and for all the troubleshooting you did so far!

    I used Browserstack to try to replicate it on Chrome 83/Win 10 but couldn’t so could you please provide me with a bit more details?

    Specifically, can you please follow the link in your Console error (should be https://js.squareup.com/v2/paymentform if it’s the same issue for all fo you), then click on the lock icon > Certificate (https://d.pr/i/0ITqRG), then expand the details of the certificate and send me a screenshot (should look something like this: https://d.pr/i/PsdN5k).

    Looking forward to hearing back from you!

    bsktbllsam

    (@bsktbllsam)

    Although it looks a little different on my screen, it shows the same information. However, when you scroll down it does show a caution mark on the “Key Usage” https://imgur.com/w69y9Cb

    Thread Starter Marlon

    (@marlonlamancio)

    Thank you @realcurtgranger for testing it on my website.

    Please let me know if rolling back to prior versions of WooCommerce and Square plugin solved it, although I think the problem is between Windows 10 and Square’s SSL certificate validation.

    One of the customers who was having an error after updating Windows 10 with the latest updates managed to resolve it.

    I was not able to reproduce the error on my side, I managed to get a customer to send me the error that was appearing in the console log but it is very difficult to contact customers to keep asking for this type of information.

    Thank you guys

    Thread Starter Marlon

    (@marlonlamancio)

    Hi folks,

    Just for the sake of the record, I tried again and now I received another error and a warning:

    Uncaught Error: Syntax error, unrecognized expression: form.woocommerce-checkout [name=]
        at Function.ea.error (jquery.js?ver=1.12.4-wp:2)
        at ea.tokenize (jquery.js?ver=1.12.4-wp:2)
        at ea.select (jquery.js?ver=1.12.4-wp:2)
        at Function.ea (jquery.js?ver=1.12.4-wp:2)
        at Function.a.find (jquery-migrate.min.js?ver=1.4.1:2)
        at n.fn.init.find (jquery.js?ver=1.12.4-wp:2)
        at n.fn.init.a.fn.find (jquery-migrate.min.js?ver=1.4.1:2)
        at a.fn.init.n.fn.init (jquery.js?ver=1.12.4-wp:2)
        at new a.fn.init (jquery-migrate.min.js?ver=1.4.1:2)
        at n (jquery.js?ver=1.12.4-wp:2)

    A cookie associated with a cross-site resource at http://squareup.com/ was set without the 'SameSite'attribute. A future release of Chrome will only deliver cookies with cross-site requests if they are set with'SameSite=None'and'Secure'. You can review cookies in developer tools under Application>Storage>Cookies and see more details at https://www.chromestatus.com/feature/5088147346030592 and https://www.chromestatus.com/feature/5633521622188032.

    My system details:

    macOS Catalina version 10.15.5 (19F101)
    Chrome Version 83.0.4103.97 (Official Build) (64-bit)

    • This reply was modified 1 year ago by Marlon.
    • This reply was modified 1 year ago by Marlon.
    Plugin Support Elvira K

    (@treibalen)

    Hi there

    @bsktbllsam,

    Thank you for the screenshot. Am I right that you got it from the machine where you could see the issue with checkout?

    @marlonlamancio,

    With that error, were you able to type in Square fields?

    I’m currently checking with Square if they saw such certificate errors for https://js.squareup.com/v2/paymentform before and will get back to you when I have an update.

    Cheers!

    bsktbllsam

    (@bsktbllsam)

    Hey,

    @treibalen yes, it was from that machine. It has since resolved itself through no effort of my own, it seems it was a problem for 24 hours. Not sure what happened, but it’d be good to know how to prevent it from happening again!

    Plugin Support Elvira K

    (@treibalen)

    Hi there @bsktbllsam,

    Thank you for confirming!

    We worked with Square in trying to replicate this issue with no luck. It seems like some specific machines have had a bad Certificate Authority installed.

    If you see the same Console error again, please get back to us with a screenshot from Dev Tools as well as a screenshot of a certificate as I asked above.

    I’ll keep the thread open for a while to see if we get more complaints, however, please note that we’re looking at this particular error message in Console:

    paymentform:1 Failed to load resource: net::ERR_CERT_AUTHORITY_INVALID
    wc-square.min.js:220 Uncaught ReferenceError: SqPaymentForm is not defined

    If you can’t type in Square fields, but see a different error in Console, please open a new thread.

    Cheers!

    Thread Starter Marlon

    (@marlonlamancio)

    Hey guys

    After so many errors and complaints from customers that they are not able to make payment on the website, my customer has given up using Square and we are returning to PayPal. Unfortunately.

    Thanks for everyone’s input and answers.

    Do I leave this thread open or mark as resolved?

    Plugin Support Joey – a11n

    (@jricketts4)

    Hi @marlonlamancio – I’m sorry to hear that, but we totally understand. I will go ahead and mark this as resolved for you, since we won’t be continuing the thread.

    – Joey

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘Square Certificate Authority invalid when requesting paymentform script’ is closed to new replies.