WordPress.org

Support

Support » Installation » SQL problems

SQL problems

Viewing 15 replies - 1 through 15 (of 15 total)
  • This is an interesting project.

    I assume you’ve made it all the way through the instructions, opening the ports and such. Do the tests in step #7 work at all?

    Have you installed any firewall on the server where Mysql server is running. If you have installed any firewall, try to add web server’s (where your wordpress files are uploaded) IP in allowed (whitelist).

    Also, upload sample PHP-MySQL connection script and check whether you are able to connect or not.

    Kailash

    I have done all those steps to the best of my ability. You see Those instruction are for linux but I run my SQL Server on a windows using XAMPP

    One of WordPress’ requirement is to have MySQL. I don’t believe you can run it on SQL.

    Is your SQL server online? This isn’t a locally hosted development server right?

    Moderator cubecolour

    @numeeja

    ɹoʇɐɹǝpoɯ

    PhpMyAdmin needs to connect to the MySQL server not the Web Server where the PHP files reside.

    PhpMyAdmin needs to connect to the MySQL server not the Web Server where the PHP files reside.

    PHPMyAdmin is just an interface to manage MySQL database and you can still manage your mysql database without PHPMyAdmin. But if your wordpress files (web server) can’t connect to your remote MySQL server then your blog will not work.

    Did you properly bind your dedicated IP address to your MySQL server in XAMPP? If MySQL server is running and you have assigned proper IP address to MySQL server then you should not face any problem to connect your database remotely. Also, make sure that the port 3306 is not blocked for incoming connection in your system.

    Kailash

    I have spent the past hour try to see If it will work, I did this by making a wordpress on my server but connecting to an MySQL database on another one of my servers. About 10min ago I just succeed. Buy simply adding my servers internal IP address in the MySQL host field. So it looks like this

    Server with files:
    wp-config.php
    DB name: test
    DB username: test
    DB pass: test
    DB host XXX.XXX.X.XXX <– MySQL server IP

    My SQL server:
    In “mysql” database and “user” field

    DB name:test DB host: XXX.XXX.X.XXX <– IP address of my other server with the files.

    So it is possible. now I need to set this up to work externally. I think that has something to do with that 3306 port, but how do I open it to external connections?

    Oh and I ment to say MYSQL not SQL sorry bout that

    thanks for all the replies

    @apljdi
    It is a locally hosted server yes. But it is up to code and everything.

    anymore Ideas?

    Is your local server connected to the web via a static IP?

    yes

    anyone else? any Ideas at all? I will try even very doubtful ideas. I really need a solution

    whooami

    @whooami

    Member

    if you really need a solution, why dont you go ask these questions on the mysql support forum? Im missing why this is an issue for this forum. you are setting up mysql — you just happen to want to use it for wordpress.

    This is where general mysql support questions ought to go:

    http://forums.mysql.com/

    Furthermore, STOP bumping this thread. Read the rules.

    http://wordpress.org/support/topic/68664?replies=6

    “Bumps”. Do not bump posts on this forum. Putting posts at the top doesn’t help them get noticed here. The volunteers who try to answer questions look for those without replies first. If you bump a post, then it disappears from the “no replies” view. DO NOT BUMP.

    @whooami
    Thx for the reply, I put this thread here to see if other wordpress users have done this and know how to help me. Also I wanted to know if wordpress is compatible with this configuration.

    Oh and I am not setting up MySQL I am connecting WordPress to it.

    P.Sorry about the bump thing.

Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘SQL problems’ is closed to new replies.
Skip to toolbar