Support » Plugin: Author Avatars List » SQL overload

  • Resolved gcluley

    (@gcluley)


    Hi there

    My managed wordpress host (Pressidium) contacted me today saying that they had experienced a problem with this plugin, and asked me to pass on this message:

    ===
    For the past few hours we have seen an extreme SQL resource abuse coming from one of your plugins [author-avatars].

    More specifically the problem seems to be that a function called on every plugin initialization (thus on every WP load), that is used to do a check if the correct plugin version is installed, is running a version update through the WP options API, which always contain the same version number.

    I have added the following on line 236 in file ‘wp-content/plugins/author-avatars/lib/AuthorAvatars.class.php, making it exit from install_check() ASAP:

    return true;

    which seems to have resolved the problem for the time being. Please contact the plugin author with the above info in case they can identify & fix the problem as the above change will be overwritten during the next update of the plugin and the problem might reappear.

    ===

    I hope you’re able to look into this and resolve the issue.

Viewing 3 replies - 1 through 3 (of 3 total)
Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘SQL overload’ is closed to new replies.