Support » Plugin: BackWPup - WordPress Backup Plugin » SQL dump not working

  • Resolved cyberetto


    After updating to backwpup 3.0.1, when running the job, the SQL dump fails, saying “ERROR: Can not set DB charset to “

    [28-Feb-2013 10:37:56] 1. Try for database dump …
    [28-Feb-2013 10:37:56] ERROR: Can not set DB charset to
    [28-Feb-2013 10:37:59] 2. Try for database dump …
    [28-Feb-2013 10:37:59] ERROR: Can not set DB charset to
    [28-Feb-2013 10:38:00] 3. Try for database dump …
    [28-Feb-2013 10:38:00] ERROR: Can not set DB charset to

    The backup has to include the DB for it to be successful! How can I fix this?

Viewing 7 replies - 1 through 7 (of 7 total)
  • I have the same error.

    Same here

    Plugin Author Daniel Hüsken


    ok, fixed with next update.

    Nope, this is not fixed yet, I’m getting the same error still in 3.0.4…

    If you go to /wp-admin/admin.php?page=backwpupsettings and click the Information tab, you’ll see that Blog charset is set to ‘DB_CHARSET’, which is the root of the problem.

    To fix this, you need to set the DB_CHARSET environment variable in your wp-config.php, with the rest of your database settings. For example:

    define(‘DB_CHARSET’, ‘utf8’);

    Be careful with that…

    WARNING: Those performing new installations: There usuallly should be no reason to change the default value of DB_CHARSET. If your blog needs a different character set, please read Character Sets and Collations MySQL Supports for valid DB_CHARSET values.

    WARNING: Those performing upgrades (especially blogs that existed before 2.2): If DB_CHARSET and DB_COLLATE do not exist in your wp-config.php file, DO NOT add either definition to your wp-config.php file unless you read and understand Converting Database Character Sets. Adding DB_CHARSET and DB_COLLATE to the wp-config.php file, for an existing blog, can cause major problems.




    Same issue here, and I’m using a wp-config.php that doesn’t include a definition of the charset (per the post of @chrispix above).

    I’m getting backup files, but they don’t include the database dump.


Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘SQL dump not working’ is closed to new replies.