Support » Plugin: Swift Performance Lite » SPL not letting Cookie notice show or any floating ads on Mobiles

  • Hello,

    My SPL plugin is not letting my site show the Cookie Notice or any floating ads (toaster) on Mobiles. I tried disabling Minify Javascripts and merge Styles with no luck (if i remember right). It looks like after i empty the cache it works fine but after 2-3 minutes i get the problem again with the notice not showing up on mobiles. No problems in desktop at all.

    The page I need help with: [log in to see the link]

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Contributor Fred

    (@fredawd)

    Just visit your site and Cookie Notice is working for me on mobile device. Probably you need to clear cookies (cookie_notice_accepted) in Mobile browser.

    Thanks, you are totally right about the cookie notice.

    The problem only limits itself to the Toaster ad, which is being somehow replaced by another ad that is not suppose to show on mobiles but on desktops.

    Im using ad inserter and configured it to show only on mobiles. This works fine when i disable the SPL otherwise ads shown are the desktop ads (which are configured to show only for desktops).

    Right now i removed the toaster ad due to this problem and replaced it with another.

    Any idea what could be the problem? Im not sure if im doing something wrong. All i know is the toaster was working before enabling the SPL. Of course i want to keep the benefits of the SPL and get the toaster to work.

    Thanks.

    Plugin Contributor Fred

    (@fredawd)

    Start with disabling merge Scripts and see if that solve your issue regarding Toaster ad.

    Heres what i did:

    I disabled merge scripts options and dismissed the “clear cache” window.

    Then i manually cleared the cache for 1 entry (because it takes a lot to cache all the entries again) and the ads shown are still the desktop version.

    Toaster code isnt even being inserted i think.

    still no luck. Been fighting with the problem for 2 days, i can’t seem to find whats going wrong.

    Plugin Contributor Fred

    (@fredawd)

    I`m sorry to hear, but configuration is not included for Swift Lite.

    It’s not a configuration thing, i think this is a design flaw or at least can be called a compatibility problem. It is messing with another plugin (ad inserter) and the code is not showing where its suppose to show.
    Don’t get me wrong its an excellent plugin but can you make another suggestion so i can keep troubleshooting this? or have someone look at the code for me? (dont think that will happen).

    Well, i ended up doing what i didn’t want to 🙁 I disabled swift performace lite plugin for now, until i find what is wrong with not letting the toaster ad show.
    Publicity is what pays for the hosting expenses; cannot sacrifice income for speed, at least not for now.
    Installed autoptimize plugin and getting a so so performance that is not affecting the toaster ad.

    Installed autoptimize plugin and getting a so so performance that is not affecting the toaster ad.

    AO as opposed to Swift does not do page caching, so install a page cache (WP Super Cache or KeyCDN Cache Enabler or …) to complement AO maybe?

Viewing 9 replies - 1 through 9 (of 9 total)
  • You must be logged in to reply to this topic.