Support » Plugin: Media Sync » Spins endlessly

  • Resolved babdon

    (@babdon)


    When I click “import selected” the spinner just spins endlessly without stopping. It seems to happen sporadically regardless of how many items I try.

    24 items work sometimes, then 8 won’t work and vice versa. It’s very strange.

    It works, then decides not to work after a while.

    • This topic was modified 1 year, 2 months ago by babdon.
    • This topic was modified 1 year, 2 months ago by babdon.
Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Author erolsk8

    (@erolsk8)

    Hmm I’m not sure how to replicate this and find out what is the issue.

    Please let me know if you can catch some error and show it here. Or provide some more details on how to replicate this issue.

    shkaf

    (@shkaf)

    Oh it seems like i have the same issue

    same problem :\

    EDIT: after the fix suggested in the plugin page it worked (add set_time_limit(300); to wp-config.php)

    thanks!

    EDIT2: it’s so slow I’m wondering if it’s worth it… could it be faster to just upload everything again?

    • This reply was modified 6 months, 2 weeks ago by oguido.
    • This reply was modified 6 months, 2 weeks ago by oguido.
    Plugin Author erolsk8

    (@erolsk8)

    I’m glad you found that tip in the description.

    Regarding the speed, it will depend on server performance and number of items being imported.

    This plugin imports items in small batches (to avoid hitting the timeout, a.k.a. spins endlessly issue), so yes, it takes a lot of time because of that. Not sure if it would help, but these are current batch sizes:

    • 1 (importing 1 to 10 items)
    • 5 (importing 11 to 100 items) or
    • 10 (importing more than 100 items)

    One day, there will probably be an option to set custom batch size to a much higher number. So that when server settings are tweaked to cope with long execution times, it would be possible to import a lot of items in one batch (making everything finish faster). But current setup is optimized to be suitable for most common use cases.

    r1bryan

    (@r1bryan)

    Import selected spins endlessly. Tried disabling all my plugins that didn’t help. Changed my wp-config file to add set_time_limit(300), that didn’t help. Changed my php.ini file to max_execution_time 300. That didn’t help. Anything else I can try?
    Just what I need if I can get it to work.
    Thanks
    Randy.

    Plugin Author erolsk8

    (@erolsk8)

    Hi @r1bryan, maybe you can find what’s the issue in network tab:
    https://www.section.io/blog/chrome-developer-tools-tutorial-network/

    When you run the import, you should see new network requests and there you might see what’s actually happening in the background.

    Please let me know if you find anything there.
    Thanks
    Erol

    r1bryan

    (@r1bryan)

    Found that for me when Object Cache is enabled in the W3 Total Cache Plugin, that causes the endless spin of import selected. I dont know anything about Object Cache but from the description it appears not to be very important. Disabled Object Cache and now Import is working. YES!

    Plugin Author erolsk8

    (@erolsk8)

    Wow that’s great! I’m glad you found what was causing it. I’ll definitely have to try it with that plugin and “Object Cache” and fix it somehow.

    Thank you very much for sharing what you found.

Viewing 8 replies - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.