Support » Plugin: Contact Form 7 » Spinning Icon, message sends, but no confirmation

  • Resolved ACM

    (@academy-of-contemporary-music)


    i know this has been posted here before, but I’ve tried everything I could find that applies to this issue…

    I’ve moved my site to a different host. since moving, the contact form 7 forms DO send mail, but just get the spinning icon, and no ‘your message was successfully sent’ message (so user’s keep clicking send over and over!).

    i’ve disabled all other plugins and still have the same issue.

    i do have several other sites which have been moved to the new provider (WP-Engine), all of which use CF7, and all the others seem to work..

    can anyone help?

    http://wordpress.org/extend/plugins/contact-form-7/

Viewing 15 replies - 16 through 30 (of 31 total)
  • I’m using CF7 3.3.2 and WP 3.4.2

    ACM

    (@academy-of-contemporary-music)

    thanks carmano, looks like a cache plugin conflict indeed..

    interestingly, I no longer have WP-Super-Cache installed, but instead, the hosting company supply their own cache features, along with a WP plugin to control it. With that turned off, everything works again.

    thanks for helping point me in the right direction. i’ll see if the host have any ideas on this conflict..

    hi there! I’ve the same issue. Spinning icon, email received but no confirmation on the page or error messages (it seems an Ajax problem)

    I’m using WordPress 3.5 and Contact Form 3.3.2 (also, using WP-Mail-SMTP plugin)

    Try everything: switch to default theme, deactivate all plugins, remove my jquery code and try lot’s of “miracle” fix I’ve found on web. Nothing works.

    So now I tried a “downgrade” to WP 3.4.2 and boom… it works fine (and even without WP-Mail-SMTP plugin as usual).

    I really like to use WP 3.5 but don’t have a clue how to fix the Ajax problem.

    I have this same problem and the above solutions have not worked for me

    I’ve installed WP 3.5 in another directory and try with Contact Form 2.4.6. It works ok!

    I have the same issue as well – email fine, error messages working, but success message does not show. I have tested many things and the only change that corrects this is to take out the code for the GA tracking in the additional setting section. Is there any solution besides skip GA tracking or downgrading the version of either WP or the CF7? At this point I am just turning off the GA Goal Tracking.

    So I was sitting here doing everybody’s recommendation. I’m getting the same issue. User would put information presses send, the spinning icon keeps spinning but message is actually sent successfully. No errors via firebug either.

    I have tried almost every ideas.
    – Downgrading to an older version of CF7
    – Disabled all plugins. Even deleted myPHP Database
    – Took of any Analytic codes, any cache plugins.

    This seemed to have WORKED~!
    So I tried what @fabian was doing, and started to edit “contact-form-7\includes\js\scripts.js”

    As I decided to backup the original file renaming it to “scripts_old.js and dragging it to my desktop (using FileZilla FTP) Anyways I started to mod the original file via Dreamweaver. I tried refreshing my Page with the form, not realizing I don’t have the “scripts.js” file on the actual server its still on my desktop. The form submitted successfully! So I tried several test runs and it all worked. The only difference is that The animation of the box with green border that says your submission is successful doesn’t animate. Instead it seems the page refreshes.

    So my fix delete/backup scripts.js see if that helps!

    Also since this ruins the whole purpose of AJAX here’s a temp fixed to the added url when screen is refreshed from submission. I got this from an older post 3 years ago

    Hi All,

    I had same problem. AJAX was not working in IE. I’ve tried IE6 and IE7. My html was valid… but there was just loading icon and nothing hapanned even if it was working in firefox withou issues.

    For me solution was to clear form action url which is in format:
    URI#unit_tag, for example /blog/#wpfc7_blabla

    It is enough to remove #wpfc7_blabla part. You can do it directly in plugin sources in includes/classes.php or you can add following code into functions.php of your theme to clear URL:

    function fix_wpcf7_ajax($url) {
    return ”;
    }
    add_filter(‘wpcf7_form_action_url’,’fix_wpcf7_ajax’);

    Unit tag (#wpfc7_blabla) is good for non ajax calls, because after page reload you will jump directly to form, but i can live without this but with working ajax with IE 😉

    I turned off all of the plugins and still had a problem. Figured out it was the theme.
    I have found there is an issue with my theme and Contact Form 7 new 3.3.3…. went back to default theme and form works.

    I figured out what was happening, my “wp-blog-header.php” was somehow hacked or injected with a script that was causing my whole site to go Quirks Mode in IE, but looked normal on all other browser. But this script was also causing AJAX not to work correctly thus validating submissions incorrectly.

    After replacing the file, everything works and submissions now work properly.

    I had the same issue. Mine was because I am on a Windows Server and had the captcha module installed. It was having issues deleting the files for the captcha and throwing a warning. Edit really-simple-captcha.php and anywhere you see unlink change it to @unlink. It should be around lines 190 & 215. There is actually a better fix to actually resolve the delete issue but this is a quick fix so messages can send again.

    To fully resolve this issue, see: http://wordpress.org/support/topic/plugin-really-simple-captcha-function-cleanup-unlink-permission-denied?replies=14

    If you do not fully resolve the issue, eventually your website will slow down drastically.

    Thanks Tee888!

    I clone my sites to start a new site (saves a lot of time) and I have been battling the “spinning icon, email send, but no confirmation”.

    I deleted all plugins, removed captcha and tried everything suggested for this problem on the entire internet.

    Only deleting (I chose to rename) the scripts.js fixed the problem.

    I don’t get the spinning icon anymore but I get my confirmation message and the email is sent and received.

    Thanks again!

    Bill

    Why did someone mark this as Resolved? It has not yet been resolved.

    I have a problem where some people who submit the form do not experience any problems, while other just see the spinning icon after submission. They never get the messages. The data is being submitted, but some people are submitting it 10 times.

    No matter which browser I use, the forms work correctly for me, but not for some users, even when they try multiple browsers.

    esmi

    (@esmi)

    Forum Moderator

    This a 4 month old topic started by someone else. They marked it as resolved. Please post your own topic.

    I had the same problem and resolved it. I was using the Configure SMTP plugin and had debug turned on. Turned it off and everything worked great.

Viewing 15 replies - 16 through 30 (of 31 total)
  • The topic ‘Spinning Icon, message sends, but no confirmation’ is closed to new replies.