Support » Plugin: WP Jump Menu » Spinning icon for WP Jump Menu in Admin Bar, no menu on click

  • Thanks for this wonderful plugin. Unfortunately, the past few revs have resulted in a spinning icon to the right of “WP Jump Menu >>” in the Admin bar, and clicking produces no menu. I’ve just downloaded 3.5.3 and no change. I’ve also complete deactivated, deleted and reinstalled 3.5.3 with no change.

    WP Jump Menu has worked fine on this site until recently and continues to work properly on a similarly configured site (that, albeit, has few plugins). I’m using the latest Genesis, Dynamik, Beaver Builder, WooCommerce, DAP and a host of other plugins, all of which are current. I would try disabling other plugins now in search of a conflict, but this is a live site in the middle of a campaign.

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author James Krill


    Hi Jeff,

    Sorry for the inconvenience.

    Try 3.5.4. I anticipate there might be no change, but let me know if there is.

    If you still have the spinning icon, check your javascript console for errors.

    Cheers, Best of luck.


    I have the same issue in one of my sites. Checked the javascript console for errors, but found none.

    I’m using version 3.5.7 now with WordPress 4.5.4. It used to work, but I don’t remember what update caused it not to work anymore.

    Any further ideas?

    Thanks in advance!


    Plugin Author James Krill


    Try clicking on the text next to the spinning icon (usually it says WP Jump Menu). That should “reload” the jump menu. Might work.

    If not, try:
    * Deactivating and then activating the plugin
    * Deleting the plugin and then reinstalling the plugin

    Sorry for the inconvenience. Let me know if that helped…

    Thanks for the reply. I’ve again deleted and reinstalled with no change. I was, however, able to get the menu to appear (exhibiting some jumpy scrolling) using the deprecated option for top of screen.

    I’m using the latest version of everything.



    Hi guys, thanks and I also checked again. Deleted and reinstalled but also no change.

    The Top of screen option works at my site as well. However I like the WP admin option better 🙂

    I’m using the latest WP version now.

    Thanks anyway, let me know if there’s something more I can try or if I can look something up for you.


    Update: With WP Jump Menu activated and set for Top or Bottom, it breaks my site (both front and back end) in Mac Firefox. Mac Safari and Chrome OK. I did have the front-end option on, so that might account for it. Nonetheless, after realizing our site was inaccessible via at least Mac FF for a day, I’ve gotten gun-shy from using this deprecated option and elected to bail from WP Jump Menu completely pending a proper fix.

    I very much hope the main issue gets resolved so I can use and recommend WP Jump Menu again. Thanks for all you do!

    Plugin Author James Krill


    Sorry, Jeff.

    If you want and are able to, you can email me directly at and give me access to your WordPress admin and I can see for myself what is going on.

    If not, it’s really hard to troubleshoot what is happening blindly.

    I have seen the spinning happen for one reason: cross-domain blocking. This happens because the menu loads via ajax, and if you are on a virtual host or your site url is setup incorrectly, the ajax part won’t worry (gets blocked) and the spinner sits there. I’ve had this happen when developing sites where I am using browser-sync or some other tool to launch a server that uses a url proxy.

    I wouldn’t use Top or Bottom positions – those were originally used before the WP Admin bar even exists. Some people still use it so I keep it in there, but the ideal is to set position to WP Admin Bar.

    Unfortunately, there’s not much I can do for you without some sort of error report.



Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Spinning icon for WP Jump Menu in Admin Bar, no menu on click’ is closed to new replies.