WordPress.org

Forums

Contact Form 7
Spinning arrow icon shows forever (7 posts)

  1. levivene
    Member
    Posted 2 years ago #

    I am using WordPress 3.5.1 and Contact Form 3.4

    My form shows well but when you click on submit, the spinning arrow shows forever, nothis happens.

    Could you please help me?

    Thanks!

    http://wordpress.org/extend/plugins/contact-form-7/

  2. levivene
    Member
    Posted 2 years ago #

    And I don't get any emails...

  3. biswajeet
    Member
    Posted 2 years ago #

    Symptoms for script error. And obviously this leads incomplete send operation & hence no email!

  4. skippywp
    Member
    Posted 2 years ago #

    I am also getting the spinning arrow. The form works and sends the email, but the spinning error continues with no success message. I tried 2 different email names/domains.
    I am on HostMonster with WP 3.5.1 and Contact Form 7, 3.4.

    Note: I also have the same configuration on HostGator and it works fine as I get the success message and the emails.

    The only difference that I can determine is the hosting. Any ideas?

  5. lattyak
    Member
    Posted 2 years ago #

    For skippywp, it's a combination of 2 problems. The server responding with an error, and the client javascript not handling the error.

    Super Cache is putting an html comment with an error message in the JSON response. And the javascript controlling the form in the browser silently fails parsing it, and then never turns off the spinner, nor puts up an error message.

    Discovered the problem by looking at the response in the Web Console.

  6. skippywp
    Member
    Posted 2 years ago #

    lattyak - Thanks! Your solution led me to look at the wp-config.php file. It showed that Super Cache had put a url in that file and the path was not correct. I had restored the site from HG to another hosting solution, HM, and the path was still showing HG's path. I fixed the path in the wp-config.php and now the send button works perfect!
    Thanks much for taking the time!

  7. k95zt01
    Member
    Posted 2 years ago #

    I have the same problem as skippywp but I'm a total newb. Can someone help explain to me how I am supposed to fix this? People are submitting to us through our website but get the spinning arrow forever on both our submissions page and our contact us page. I get the email but they don't get the information that it was successful and therefore send it 50 times to us. I'm on godaddy. I have been using this plugin for years with no problems. Updated plugin and wordpress. 3.5.1 and plugin 3.4.

    Thanks!

    http://www.magnetmanagement.com

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Contact Form 7
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic