Support » Fixing WordPress » Spellchecker non functional?

  • I’m on version 2.1 of course, and had absolutely no issues getting it updates from my previous. However, one of the new features (duh) is an integrated spellchecker.

    However, when I test it, by knowingly spelling something incorrectly, it tells me there are no mis-spellings.

    Do I need to have either a plugin installed, or something resident on my hosts server for this to function properly?

    I looked in the release notes, but may have overlooked if it says so.

    Any insight or advice is greatly appreciated!

Viewing 15 replies - 1 through 15 (of 19 total)
  • Moderator Samuel Wood (Otto)

    (@otto42) Admin

    If your version of PHP is compiled with pspell support, it will use that.

    Failing that, it will check your server for the /usr/bin/aspell program, which is the standard unix spell checker.

    Failing that, it will try a Google Web Service to check your spelling (the same one that the Google Toolbar uses).

    If none of these are available, I have no idea what will happen. Perhaps it would cause that message you saw. Dunno.

    TinyMCE spellchecker 1.0.3 released. Don’t know what version is in wp 2.1. But assuming aspell and pspell isn’t working (doesn’t work for me), the Google spell option required curl (used to). The new spellchecker release fixes that.

    “Fixed so that curl isn’t required for the Google speller class if you use PHP 4.3.0+.” (from )

    But, I downloaded the spellchecker and replaced the one in wordpress and it still didn’t work (got an AJAX error server not returning XML)?

    Maybe there is a way to include the new plugin into wordpress and someone knows how to do that?

    Moderator Samuel Wood (Otto)

    (@otto42) Admin

    The version of the TinyMCE spellchecker in WordPress is given as 1.1 (2006-03-14), and as far as I know, it should just be a drop it in thing. I don’t think that the TinyMCE plugins are altered from their original state.

    Also, the Google spellchecker class doesn’t appear to use curl. It’s using an HttpClient class which, as far as I can tell, uses direct socket connections (fsockopen and fwrite and such). No mention of curl anywhere.

    Somebody help.

    The spelle checker doesn’t spell. I’m not sure what software is running on the server, but I am sure that I have the google toolbar installed.

    I used to use Ajax-Spell Checker before, but I just upgraded to 2.1 and things are broken.

    Moderator Samuel Wood (Otto)

    (@otto42) Admin

    2 things:

    1. The built in spell check won’t work on all servers. This should be fixed in the next release.

    2. The Firefox built-in spell checker is disabled by default. Plugin to fix this can be found here:


    I just upgraded to WP 2.1.2 from 2.0.5 and am having the same problem as oseary (above) and Auke ( concerning the new spellchecker not functioning. I get the message “No misspellings found.” no matter what I type. I am using IE7 and think I am starting to understand a little about this after reading several other posts several times on the same issue, but I am still confused a little.

    It looks like my ISP does not provide support for pspell, and I am assuming they do not for aspell (they did not respond to that question). So it looks like 2 of the 3 checks Otto42 mentions above will not happen. I have no idea why the Google Web Service does not check, but it looks like none of the checks are working.

    After playing with IE7 and Firefox 2.0, I noticed that automatic spellchecking works in Firefox for me, but if I use the WP spellchecker button I get the same message as I do in IE7, “No misspellings found.” This leads me to believe that the WP spellchecker function just will not work for me at all no matter what browser I use. The Firefox solution looks like it is just a browser solution, it looks like it does not fix the WP problem. Does that sound right? I know someone is just going to tell me to use Firefox, but I do not like it just like many people do not like IE or Netscape.

    Otto42, you mention a fix in the next WP release for all servers. I assume that will fix my problem of none of the checks running. That would be great. The spellchecking feature is the main reason I upgraded. Oh well.

    Does this sound right or do I have it all wrong. Thanks for any help and assistance you may be able to provide.

    I upgaded recently and am using 2.1.3. I get the error message:

    Could not execute AJAX call, server didn't return a valid XML.

    The Firefox spell checker seems to function, but the Mac system checker does not.

    Anyone know in what version this will be resolved?

    I upgraded to version 2.2, and the spellchecker still gives the AJAX error.

    I had exactly the same problem after upgrading from 2.1.3.

    The spell checker was working beautifully before the upgrade. It was fast and efficient. After the upgrade everything slowed down terribly–painfully, with “please wait” messages or else the Ajax error. So much for an “upgrade”!

    I solved the issue by simply renaming the spellchecker directory in wp-includes/js/tinymce/plugins and copying in my old spellchecker directory from my previous version (I’d saved everything before the upgrade). I then logged in again and the spellchecker worked as it did before.

    I haven’t fully tested it but it seems to me like the spell checking is back to normal. Something else might be affected by doing this but I haven’t noticed any problem yet.

    stephen61: Thank you for posting. I did exactly the same as you – removing the current spellcheck directory and uploading the spellcheck directory from a previous wordpress version and wallah! Spellcheck now works again flawlessly.

    Others who are experiencing problems with spellcheck in the new versions may want to do the same.

    Hey stephen61 and MacAddict,

    I too am getting the infamous “Could not execute AJAX call, server didn’t return a valid XML.” message when I try to spell check in WordPress 2.2.1 using a Macintosh running either Firefox, Camino 2007022813 (1.0.4), or Netscape Navigator 9.0b1.

    Which older version of WordPress should I get the “old spellchecker directory” you are speaking of?

    Hey WordPress folks!

    Are you aware of this bug? If so, are you working on a fix? If you are, will the fix be in the next update of WordPress? I sure hope so!

    TIA to all who answer 🙂

    I am receiving this “XML” error as well – WordPress 2.3. Please advise.

    I’m getting the “XML” error as well, and using WordPress 2.3 as a new install. TIA for help on this.

    I no longer get the error, but the spell check returns “no mispellings found” when in fact there are mispellings. Anyone else getting this type of errors?

    Moderator Samuel Wood (Otto)

    (@otto42) Admin

    Can you give a specific example of what is spelling wrong but not being caught?

Viewing 15 replies - 1 through 15 (of 19 total)
  • The topic ‘Spellchecker non functional?’ is closed to new replies.