WordPress.org

Support

Support » Plugins and Hacks » Spellcheck Error

Spellcheck Error

  • Oy, on top of my shortstat issue!…

    Spellcheck gives me this error:

    Error executing ‘usr/bin/aspell -a –lang=english –personal=/home/katehack/public_html/wordpress/wp-content/spell-plugin/aspell_data_9dPQxn 2>&1’

    Error: (question mark with a diamond);.

    Sup with that?

Viewing 11 replies - 1 through 11 (of 11 total)
  • your host doesnt have the aspell libs installed or the path they have them installed to is different than whats expected — its probably the former.

    It worked before today, how odd.

    Also, I downloaded the plugin again……. there IS no aspell_data file.

    Spellcheck gives me this error:

    If that’s your error verbatim, double-check you aspell path… as you’ve listed it — usr/bin/aspell — it certainly won’t exist. Make sure it’s actually /usr/bin/aspell.

    there IS no aspell_data file

    The aspell_data_something files are temporary files created when you actually run a spell check and deleted when finished.

    Sorry, that really wasn’t helpful. I know — usr/bin etc. doesn’t exist. I don’t know why it’s looking there.

    The name & path to aspell executable is set to in the settings area:
    /usr/bin/aspell and to the personal dictionary /home/katehack/public_html/wordpress/wp-content/spell-plugin/aspell.personal

    I had problems with the spell check plugin at first. In the options menu, the language was defaulted to en_US, which was causing the error. When I changed that to just en it worked.

    Also, don’t forget to chmod the spell-plugin directory to 777. Otherwise, it won’t be able to create the aspell.personal and error_log files.

    See, it’s worked before. I just don’t knoww hat I did to make it stop!

    HOLY CRAP!

    I got it!

    I changed the lang. to en from english.

    THANK YOU! 🙂

    I had the same problem & another member pointed me to this thread & it just fixed my problem too. Does the plug in author know about this issue?

    Thanks so much prissed…

    Moderator James Huff

    @macmanx

    ColdForged is the author, and since he has left his comments in this thread, I am sure that he is aware of the issue.

    richards1052

    @richards1052

    I reported back in May that I’d gotten Spellcheck to work by changing the aspell language setting to ‘en’. Alas, the plugin’s no longer working. I still have the language set to ‘en,’ the files are CHMODed to 777, & I’ve deleted the previous installation of the plugin & tried reinstalling. But I’m still getting this error:

    “sh: line 1:/usr/bin/aspell: no such file or directory.”

    Under “Name and path to aspell executable,” is the setting supposed to be:

    ‘/usr/bin/aspell’ ?

    I can’t think of what else could be wrong but perhaps someone else can?

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘Spellcheck Error’ is closed to new replies.
Skip to toolbar