WordPress.org

Forums

Spell Checker Multiple Errors (1 post)

  1. cyndin
    Member
    Posted 7 years ago #

    Using WP 2.3.1 in Mozilla 1.7.2 on a Mac G4 running 10.2.8.

    I searched wordpress.org but could not find anyone else reporting these errors, so I suspect it might be on my ISP's end. They had trouble installing spell checker at first but then it worked. No response yet to this report, but if I can bring them something specific to work with, they are sure to follow through. They've allowed users to install their own WP for a long time but they're new to providing it.

    Spell checker loads fine and highlights the mispelled words. If I go to click on a highlighted word, it gives me a pop up with a bunch of options to change the word to. But I can't choose any of them. Nothing works. I have to memorize correct spelling I want, put the cursor on a word next to the highlighted word, use the arrow keys to get to the highlighted word, then the delete key and typing in the correct spelling. Repeat as many times as needed until it's right.

    The highlighting doesn't disappear when the word is right. You have to click again and if it shows no options, then you assume it's right. If you click on the spell tool (in the menu) to turn it off, then turn it on again, corrected words will no longer be highlighted.

    When you click on the highlighted word and let go, it pops you back to the screen that showed when you turned the spell tool on. Which is a pain if you have a bunch of text to scroll through to see all the highlighted words.

    The worst bug of all though is that after you're done with the spell tool and turn it off, most of the words you've corrected lose their space before or after the word and merge with the word next to it. Turning the spell tool back on does not show these merged words as highlighted. You have to remember where the mispelled words are and go back and correct by hand.

    Here is a (made up) example. Original text is:

    Wow I am so hapyy to have a new blog.

    Turn on the spell tool and "hapyy" has red underlining.

    Click on "hapyy" and it suggests "happy" in the popup. But choosing it does nothing.

    Since I can't put my cursor directly on "hapyy" I have to put it elsewhere, like on "to." So I do that, use the arrow key to get to the extra "y," eliminate it and add a "p."

    Now I turn off the spell tool and I'm ready to publish, right? Nope. Now the line reads:

    Wow I am sohappy to have a new blog.

    I have to remember to look for that (not so easy with a couple pages of text) and add the space back in. Now I have my correct version:

    Wow I am so happy to have a new blog.

    Thanks for any insights.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags