Support » Fixing WordPress » spell check plug in not working

  • Hi. I upgraded from Fedora Core 3 to Core 4. I installed it new then copy all my data over. My wordpress and data base. It’s working real good but when I got to my spell checker it gives me an error and I can not find out how to fix it. I did do the en but that don’t help. I have my folders all chmod to 777 for it. I don’t know what is wrong.

    If you like to see the error I am talking about I got a jpg photo of my that part of the screen here:

    I reinstalled it too from the 1.17 to the 1.18 but I get the same error.

Viewing 4 replies - 1 through 4 (of 4 total)
  • try typing aspell in your terminal to see if its installed.

    if not you might like to try this version of ajax spell checker which uses google spellcheck webservice.

    It looks like aspell is installed. I got this back and a lot more.

    “[root@small tmp]# aspell

    Aspell 0.50.5 alpha. Copyright 2000 by Kevin Atkinson.”

    I did install the Ajax Spell Checker from the link you gave. But it looks like it’s not working ether. It downloaded as a zip file. I unziped it right to “wordpress\wp-content\plugins” then deleted the zip file. It has a folder now in the plugins named “spell_checker” that’s were all it’s files are and one other, the “ajax-spell-checker.php” in in the plugins folder too. Is this the right way?

    All I get when I click on the blue color text “Check Spelling” is “Error on page.” in the buttum left corner. Nothing else happends.

    If I click on the “Activat Spell Check while Typing” It makes a blank spot just over the part were you type and if I typed I only see the letters for a sec. and they don’t move over to the right.

    I can type in the blank spot but every thing I type is under line in read. Wrong or right words.

    So it seems like this Ajax spell checker is harder to get working then the other one.

    -Raymond Day

    Hay it looks like I fixed it! I guess that /tmp is not “writeable by the web server”. I seen this file, “aspell-word-list.txt” at “/var/www/html/wordpress/wp-content/spell-plugin” so I put that folder as my “Path to use for temporary files ” and the Spelling Checker will not come up with the error any more!

    How would I get it so the web server can write to the /tmp folder? It must of been set up like that on my Fedora core 3.

    -Raymond Day

    try using chmod or chown command

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘spell check plug in not working’ is closed to new replies.