Support » Plugin: Google Analytics Germanized (GDPR / DSGVO) » Speichern nicht möglich

  • Resolved hnuecke

    (@hnuecke)


    Ich habe Schwierigkeiten, Einstellungs-Änderungen zu speichern.
    Bei der ersten Parametrierung hatte ich schon einmal dieses Problem, konnte mir aber selber helfen (es fehlte anscheinend die MIME Deklaration für PNG. Nach der Ergänzung konnte ich speichern und nahm an, das Problem sei gelöst).
    Jetzt habe ich aber dasselbe Problem wieder. Es kommt die Fehlermeldung:
    “(website) says:
    Save changes failed. REST API not available!”

    Wie schaffe ich es, Änderungen zu speichern, ohne das Plugin neu zu installieren und alle Eingaben erneut zu machen zu müssen?

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author Sascha Rudolph

    (@sascharudolph)

    Hallo Hnuecke,

    diesen Fehler können wir nicht direkt nachvollziehen und müssten wir gesondert pürfen. Du kannst dafür unser Support-Formular nutzen und unseren Support direkt ein Ticket schreiben.

    -> https://www.pascal-bajorat.com/support/

    Vielen Dank!
    Sascha

    sotte

    (@sotte)

    Hallo,

    darf ich fragen, was das Problem war? Ich habe nämlich gerade selbiges…

    Viele Grüße

    hnuecke

    (@hnuecke)

    @sotte
    Ich habe noch einmal in meinem “Logbuch” nachgeschaut und diese Anmerkungen gefunden:

    • Löscht man während einer WP Sitzung die Cookies (right click im „secure“ Feld links von der Adresszeile), dann findet das Plugin ein Cookie nicht mehr (nennt das zwar „NONCE“, gemeint ist wohl NONE was zu dem Fehler führt).

      Lösung: Aus wp-admin aus- und wieder einloggen

    • Ist kein image/png Mime Type deklariert, kann es beim Speichern der Plugin Settings zu einer weiteren REST API Fehlermeldung kommen

      Lösung: MIME Type image/png deklarieren; am einfachsten mit einem Plugin (WP add mime type)

    Ich hatte dann keine Probleme mehr (habe allerdings keine weiteren Änderungen mehr machen müssen, aber eben noch einem einen kurzen Versuch gemacht, der erfolgreich war).

    Viel Erfolg

    • This reply was modified 10 months ago by  hnuecke. Reason: layout
    sotte

    (@sotte)

    @ Danke

    Bei mir war es ein anderes Problem. Nach dem Auskommentieren folgender zwei htaccess-Zeilen funktionierts:

    RewriteCond %{REQUEST_URI} ^/[^\.]+[^/]$
    RewriteRule ^(.*)$ https://%{HTTP_HOST}/$1/ [R=301,L]

    Diese setzen ein Trailing-Slash, wenn nicht vorhanden.

    VG

    Bin heute wieder in die Falle getappt 😉
    Ich wollte die “privacy settings” testen und hatte Cookies disabled.
    Um dies wieder rückgängig zu machen, habe ich alle Cookies der website gelöscht.
    Beim folgenden Versuch, eine Änderung im Plugin zu speichern, erhielt ich wieder die Meldung:
    “REST API not available!”

    Diesmal brachte allerdings auch ein Abmelden von WP und wieder Anmelden nichts.
    Ich habe dann stat Chrome Firefox genutzt, und damit klappte dann das Speicher der Änderungen.

    Hallo.

    Ich habe das gleiche Problem. Ich habe das Plugin heute installiert und wollte die UA ID eingeben und speichern, aber es kam nur die Fehlermeldung “Save changes failed. REST API not available!”

    Hab schon versucht mich auszuloggen und wieder einzuloggen, aber ohne Erfolg. Ich habe auch das Plugin (WP add mime type) ausprobiert, aber das hilft auch nicht.

    Hallo,
    ebenfalls das gleiche Problem heute!
    Habe mich neu eingeloggt, einen Inkognito Modus versucht und einen anderen Browser, habe das WP add mime type probiert, komme aber auch nicht weiter.

    Ich kann keinen zusätzlichen Code im Header eingeben.

    Bitte um Hilfe!

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Speichern nicht möglich’ is closed to new replies.