Support » Plugin: Yoast SEO » “Speeding up your site” takes way too long

  • Resolved cool_recep

    (@cool_recep)


    I started this process after updating to 14.0.2 but it takes way too long. Started last night and with some server problems now and then it’s still runing to this time with 120547 entries to be processed.

    It processes 25 entries in 25 seconds…

    Yoast says “This may take a few minutes.” Let’s calculate: It’ll take 33 hours.

    That is insane!

    MariaDB 10.3
    PHP 7.3
    LSWS 5.4.x

Viewing 6 replies - 1 through 6 (of 6 total)
  • Thread Starter cool_recep

    (@cool_recep)

    Solved with 14.0.4. Much faster now.

    Thread Starter cool_recep

    (@cool_recep)

    Update: Not solved. Still slow. And the worse is, I tried for hours to get it under 100K to wake up next morning and find it at 107K. WTF? Fix this Yoast!

    The only way I can get it to work is with the WP-CLI tool, and on a site with 30,000 posts it took about 14 hours. I imagine my site with 70,000 posts and 400,000+ objects is gonna take at least 24 hours on the command line.

    Thread Starter cool_recep

    (@cool_recep)

    Could you tell me about the CLI command? Thank you. It works via SSH I think.

    You need SSH access and have to follow the installation instructions here:
    https://wp-cli.org/#installing

    Then run the command
    wp yoast index

    From inside of the directory where your WordPress installation is located

    For what it’s worth, I’m 18 hours into my 70,000 post site, and only at 44% on the indexing job. Fortunately, you can just leave the SSH terminal open in the background running, and it’ll eventually complete.

    …and it’s finished. Even using the command line on a relatively fast 8-core dedicated virtual server, it took 47 hours to complete the index build for one of my websites. I sure hope I never have to do that again.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘“Speeding up your site” takes way too long’ is closed to new replies.