Support » Plugin: Yoast SEO » “speed up your site” Timeout error

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Support Michael Tina

    (@mikes41720)

    Hello,

    Just to clarify, you are using the latest version of WordPress 5.4.2 and Yoast SEO for WordPress 14.4.1? Also, you didn’t run the ‘speed up your site’ or Indexables feature in the previous versions of 14.x.x? So, when you click on the ‘speed up your site’ button, your website then times out?

    You’ve actually got several options, such as lazy loading (where you dismiss the Indexables feature and it will continue to index in the background over time), or you can try and run it through WP-CLI — https://yoast.com/help/why-does-yoast-seo-ask-to-index-a-sites-seo-data/

    Could you see if trying the other options help?

    miguelgaton

    (@miguelgaton)

    Hello,

    Yes, I’m using WP 5.4.2 and Yoast 14.4.1. I tried with 14.x.x but the same issue.

    I have tried with WP-CLI but I get this error:

    > :/media/desarrollo/depeces.com/website$ wp yoast index
    > PHP Notice: Constant ABSPATH already defined in phar:///usr/local/bin/wp/vendor/wp-cli/wp-cli/php/WP_CLI/Runner.php(1197) : eval()’d code on line 60
    > PHP Fatal error: Uncaught Error: Call to undefined function add_filter() in phar:///usr/local/bin/wp/vendor/wp-cli/wp-cli/php/WP_CLI/Runner.php(1197) : eval()’d code:63
    > Stack trace:
    > #0 phar:///usr/local/bin/wp/vendor/wp-cli/wp-cli/php/WP_CLI/Runner.php(1197): eval()
    > #1 phar:///usr/local/bin/wp/vendor/wp-cli/wp-cli/php/WP_CLI/Runner.php(1158): WP_CLI\Runner->load_wordpress()
    > #2 phar:///usr/local/bin/wp/vendor/wp-cli/wp-cli/php/WP_CLI/Bootstrap/LaunchRunner.php(23): WP_CLI\Runner->start()
    > #3 phar:///usr/local/bin/wp/vendor/wp-cli/wp-cli/php/bootstrap.php(74): WP_CLI\Bootstrap\LaunchRunner->process(Object(WP_CLI\Bootstrap\BootstrapState))
    > #4 phar:///usr/local/bin/wp/vendor/wp-cli/wp-cli/php/wp-cli.php(27): WP_CLI\bootstrap()
    > #5 phar:///usr/local/bin/wp/php/boot-phar.php(11): include(‘phar:///usr/loc…’)
    > #6 /usr/local/bin/wp(4): include(‘phar:///usr/loc…’)
    > #7 {main}
    > thrown in phar:///usr/local/bin/wp/vendor/wp-cli/wp-cli/php/WP_CLI/Runner.php(1197) : eval()’d code on line 63

    regards,

    Plugin Support Carl B

    (@devnihil)

    @miguelgaton If you choose to dismiss the option to ‘start processing and speed up your site now‘ and instead us the lazy loading option where it will continue to index in the background over time, do you still receive any errors?

    miguelgaton

    (@miguelgaton)

    No errors but I think the lazy load process is not working neither. Because if I click on the process 2-3 days later I can see the same number of elements pending (0/3471).

    regards,

    Plugin Support Michael Tina

    (@mikes41720)

    Hi,

    That’s strange. The lazy load process should index the meta data of your posts and pages slowly into the tables as your users browse your content over time.

    Could you please try to install the Yoast Test Helper plugin and reset the indexables, and try to rerun it again either via by clicking on the ‘speed up your site’ or by WP-CLI? This article may be helpful — https://developer.yoast.com/customization/yoast-seo/indexables-cli/

    miguelgaton

    (@miguelgaton)

    I works! thanks a lot

    miguelgaton

    (@miguelgaton)

    Sorry again.

    It doesn’t work finally. It start working fine but it blocked in the same point around 475/2905.

    If I restart the process again the same issue 🙁

    regards,

    Plugin Support Md Mazedul Islam Khan

    (@mazedulislamkhan)

    We are sorry to hear that you’re still having trouble with this. Unfortunately, we think the issue is specific to your site. We’d need to investigate further but are unable to do so on these forums. You can purchase Yoast SEO Premium and receive our Premium email support and we can help you further.

Viewing 8 replies - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.