Support » Plugin: WordPress Related Posts » Specifying Related Posts

  • Resolved techiechic


    Thank you so much for providing this plugin. I’m really excited to start using it to help reduce the bounce rate on my site.

    I’m having trouble specifying which other posts should be associated with my posts. I tried using the orange “Edit Related Posts” button but that just takes me back to the same page and doesn’t seem to be executing the javascript that I’ve seen described in other support threads. There’s also no form that displays on my compose screen that would allow me to select which posts to display.

    I’ve tried disabling my other plugins but that didn’t seem to have any effect and I’m at a bit of a loss. I have lots of very different kinds of content on my site so it would be very helpful for me to handpick the posts that are most relevant to one another.

    My website is I’d be happy to provide credentials for the backend if that would be helpful, but obviously wouldn’t want to post those on a public forum. Let me know if you have any thoughts on how I might remedy this.


Viewing 3 replies - 1 through 3 (of 3 total)
  • Hey Brittny, big thanks for the nice words and for being so helpful from the start — I’ll be more than happy to help you out!

    I’ll be more than glad to take a look at your current plugin setup, if possible. Would you please be so kind and send me a screenshot of your plugin settings page, with all your sub-menus expanded, so that I could have a closer look? Or just send me an email at support[at]zemanta[dot]com, if you wish to send me your credentials, as mentioned.

    In any case — all we want is to gather some information on what’s going on with your missing features and to restore them, if possible.

    Let me know, I’m eager to get it sorted! Take care & I’m looking forward to your reply!


    Hi Silvo,

    Thanks for your help. Here is a link to a screenshot of my settings page with the tabs expanded – . I will get some support credentials to you in just a few minutes.


    In case anyone else is having this problem, it turned out to be an issue with an outdated theme. Since I’m preparing for a redesign anyways I just toggle between my current design and a standard design when I want to specify my related posts and that works just fine now. Thank you SO much to Zemanta’s support team for their help! I’m very impressed with your attentiveness to helping solve my issue 🙂

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Specifying Related Posts’ is closed to new replies.