WordPress.org

Support

Support » How-To and Troubleshooting » [Resolved] Specified file failed upload test. – Can’t upload images!

[Resolved] Specified file failed upload test. – Can’t upload images!

  • I can’t upload images, I receive this error:

    Specified file failed upload test.

    I also can’t view or use images in the Gallery or Media Library, at all. What can I do to fix this?

Viewing 12 replies - 1 through 12 (of 12 total)
  • Yes, I am having the exact same problem. For some reason, RC1 gives me the same error message but I can see the images. RC2 and 2.5 final won’t even let me see the thumbnails.

    Do not post link to unrelated topics. This is not the same issue, and I am not using any plugins, so deactivating the Bad Behavior plugin is irrelevant.

    Yeah, I still can’t seem to fix this. I disabled plugins too (and didn’t have Bad Behavior in the first place).

    I tried a few other things, including removing some commas from some code and stuff like that. No success. Anybody have any success here?

    Thanks for the suggestion, but I already did that. Added the code to .htaccess and saw no change. I’ve tried with IE7, Opera, and Firefox.

    Have you seen these changes?

    http://trac.wordpress.org/changeset/7573

    And be sure to clear your cache. 🙂

    Hmm, I think it was clearing my cache that did it. I had already done all these changes mentioned, and it still wasn’t working. Now there is no error. Thanks for the help Jeff1701!

    Fixing the commas seems to help a bit, but FF is still not working right.

    For me fixing the commas hasn’t helped in any way.

    I’m on Kubuntu and tried firefox, opera and konqueror. I can upload but this message (Specified file failed upload test) always appears.

    In the end the file end up there and I can insert it into the post but it ain’t right yet.

    I can’t see why the upload dialog has to be flash anyway.

    Manfred

    I had a similar problem with my blog. Was fine until I upgraded to 2.5.
    If you have exhausted all other avenues, I would contact your host. My host (Hostgator) was blocking the upload of images for security. I had to tell them the location of all of my blogs so that they could remove the security feature. This worked perfectly.

    When I was getting the problem I was just getting “http error”, but I know some people got “crunching” instead.

    It seems that the server was logging this message: mod_security: Access denied with code 403. Pattern match “^Shockwave Flash” at HEADER(“USER-AGENT”) [id “***MY ID”][rev “1”] [msg “SpamBot UA”] [severity “CRITICAL”] [hostname “***MY-DOMAIN***”] [uri “/testing/blog/wp-admin/async-upload.php”]

    Hope this helps you guys. I spent hours trying sugegsted fixes. I never would have guessed that it was a security issue with my host. After contacting them it was fixed within the hour.
    At first they argued that it was 3rd party software, but I told them that I had a test blog and I also had blogs on 2 servers and it was the same on all of them. They referred me to their higher level support and they fixed it within an hour.

    Let me know the outcome. dave@isnigh.com

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘[Resolved] Specified file failed upload test. – Can’t upload images!’ is closed to new replies.