Support » Fixing WordPress » specific term in post URL displaying as blank page

  • Resolved aezzell2020

    (@aezzell2020)


    The page I linked to actually doesn’t exist, but it demonstrates the utter weirdness of the situation I’ve been struggling with.

    There’s a post on our staging site that displays as expected: http://rxk.547.myftpupload.com/gerard-dysico-md/

    But on the production site, which was just created by pushing the staging site last night, the corresponding URL displays as a completely blank page.

    From what I can tell, the problem appears to be related to the presence of the string “dysico” in the URL.

    This is the actual post on the live site with a changed URL so that I could get it to display: https://cookcountytrauma.org/gerard-dysic-md/

    If I manually edit the URL in the browser, I get what I would expect – a 404 page: https://cookcountytrauma.org/gerard-dysic-md-test/

    HOWEVER… if I edit it to include the term “dysico”, I get the blank page, not the 404 page: https://cookcountytrauma.org/gerard-dysico-md/

    If I look at the Page Info in Firefox, it says:
    Render Mode: Quirks mode

    If I view the source for the blank page, I just get a faint 1 in the upper left corner, but no actual HTML.

    If I try to inspect element on the blank page, I get:
    <html><head></head><body class=”vsc-initialized”></body></html>

    (I have the Video Speed Controller add-in installed. If I look at the funky post in Edge, it’s the same, but without the vsc-initialized.)

    If I take the URL of a post that displays correctly, like
    https://cookcountytrauma.org/andrew-dennis-do-facos/

    and edit the URL to add a random term like “xkcd”, I get the 404 page:
    https://cookcountytrauma.org/andrew-dennis-do-facos-xkcd/

    but if I edit it to contain “dysico”, I get the blank screen:
    https://cookcountytrauma.org/andrew-dennis-do-facos-dysico/

    I have created a brand new post with dysico in the URL – blank screen:
    https://cookcountytrauma.org/dysico-test/

    All the attending physician posts are using a custom post type. Changing that back to Standard makes no difference.

    This site (just like the staging site, where the page works) is running on GoDaddy Managed WordPress. I have flushed the Managed WP cache. I have turned off the GoDaddy CDN and then flushed the Managed WP cache. I have flushed the browser caches (Firefox and Chrome). I have run the browsers in private/protected mode. I have even flushed the cache for the added level of security that the site has – even though the problem existed before we added that security.

    I have tried different themes, including the Twenty Twenty-One theme. Same problem.

    It seems clear that something, somewhere, is somehow misbehaving due to that specific string of letters – and only that string of letters. The GoDaddy security is finding no malware or injected spam or defacement.

    The only difference that I can think of between the sites is that the production site is running HTTPS, and the staging site is running HTTP.

    Any suggestions as to where I might look?

    The page I need help with: [log in to see the link]

Viewing 3 replies - 1 through 3 (of 3 total)
Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.