Support » Plugin: Relevanssi - A Better Search » Specific post(s) are not found

  • Resolved supernaut510

    (@supernaut510)


    I noticed that search doesn’t work for at least one post. I have a post with a unique term, “utopia”:
    https://pixelpeople.com/news/website-launch-utopia-solutions/

    Using the site search, I have searched for “utopia” and “launch” but this post doesn’t come up in either of those queries. (It can not be found in the admin, either.)

    Any ideas? Thanks for any help you can offer.

    The page I need help with: [log in to see the link]

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author Mikko Saari

    (@msaari)

    If you look at that post with the tool you can find on the Debugging tab of Relevanssi settings, what does the output look like?

    Thread Starter supernaut510

    (@supernaut510)

    “Nothing found for post ID 2946.”

    Plugin Author Mikko Saari

    (@msaari)

    The post is not indexed for some reason, and thus cannot be found. Does rebuilding the index help? If not, then there’s something that’s blocking this post from being indexed. A SEO plugin noindex setting? Something else like that?

    Thread Starter supernaut510

    (@supernaut510)

    Ugh. That’s embarrassing — it was Yoast. I have no idea why it was set to not show, but that was the culprit. Thank you so much for your help. I’m sorry to bother you with my mistake! Be safe & well.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Specific post(s) are not found’ is closed to new replies.