Support » Plugin: YITH Infinite Scrolling » Specific error on Woocommerce search results

  • Resolved JapeNZ

    (@japenz)


    Hi there,
    I have an issue with infinite scrolling on my site, though I don’t know if it’s specific to your plugin or with infinite scroll in general.

    Basically I have a comic shop and while the plugin works perfectly for all pages on the site, including product catalog pages, it doesn’t work on search results pages… well it does, but only if you don’t use ‘#’ in your search.

    Due to the nature of my business a customer being able to search for a specific issue number is very important, but at the moment if someone were to search ‘Walking Dead #1’ they’d been shown the first page but when they scroll down nothing else will load… the spinner spins and then just disappears.

    On the other hand if they were to search ‘Walking Dead 1’ everything would work as expected.

    Is this a limitation of infinite scrolling or do you think there may be a workaround?
    I’ve currently set it up so the default pagination is shown on search result pages, but I’d much rather use infinite scrolling if at all possible.

    I’d appreciate any help you can provide 🙂

    Kind regards,
    JP

    The page I need help with: [log in to see the link]

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author YITHEMES

    (@yithemes)

    Hi there,

    The problem may be related to this code in the file “/plugins/yith-infinite-scrolling/assets/js/yith.infinitescroll.js:43

    desturl = decodeURIComponent (desturl);

    Try to delete it and let me know if it resolves.

    Hi there,

    I thought that had worked perfectly, but unfortunately not.
    On closer inspection it was doing the scrolling, but then repeating products already show.
    Also when I did a different search it didn’t do anything.

    Any other thoughts?

    Kind regards,
    JP

    • This reply was modified 3 months, 4 weeks ago by  JapeNZ.

    Hi there,
    So as a work around I’ve set the navigation selector to:

    body:not(.search) .woocommerce-pagination

    It works fine, however I’m not getting the loading gif come up from page 2.

    Any idea how I can fix this please?

    Actually it seems it may worked, I think I just needed to clear my cache 🙂

    Kind regards,
    JP

    • This reply was modified 3 months, 1 week ago by  JapeNZ.
Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.