WordPress.org

Forums

[resolved] Specialized page template not working. (4 posts)

  1. MaTaX91
    Member
    Posted 1 year ago #

    Trying to follow the spec on this page...

    http://codex.wordpress.org/Page_Templates

    I have a page in my wordpress called Notes, the slug to get to the page is /notes using the post-name permalink structure.

    In my theme directory (not a child theme btw) I created a page called page-notes.php

    And placed my usual get header, get footer and some content just to make sure that the page template is working; it's not.

    I've checked the page in an incognito window to make sure it's not a caching issue and it still doesn't work there. Is there any bit of code or wordpress setup that needs done to get this working?

  2. graphical_force
    Member
    Posted 1 year ago #

    So you've assigned that template (Notes) in the dropdown of that page? It will not use it unless you choose that as the template for that page.

  3. MaTaX91
    Member
    Posted 1 year ago #

    Well there is no dropdown for one, but also right on that page under the 'Specialized Page Template' heading it says that "WordPress will automatically find and use that file to render the About page" right after the two examples. Is this not the case anymore?

  4. MaTaX91
    Member
    Posted 1 year ago #

    Solved my issue, I had a static page set as my front page which wordpress was automatically trying to fix for me. I thought I needed to create a custom template for the 'Notes' page that I wanted to be my 'posts' page but it uses the index.php or home.php page automatically, I just needed to create a page-home.php file so the static front page I set up would know to use that template.

Topic Closed

This topic has been closed to new replies.

About this Topic