Support » Fixing WordPress » special characters messed up

  • Installed plugin as instructed. Immediately noticed only in IE7 that special characters were displaying garbled after being cached. For instance, bullets were being replace with garbled characters. I think apostrophe’s were messed up also.

    Tried just activating wp-cache without super cache through the plugin but the problem remained. So I uninstalled the entire plugin, reinstalled wp-cache after removing the special cache files and everything seems back to normal with no errant characters appearing. I wasn’t sure of the exact procedure to uninstall (did nothing with htaccess files).

    It did seem the html caching improved performance and I’d still like to use the plugin once this problem is eliminated.

Viewing 8 replies - 1 through 8 (of 8 total)
  • One more note:

    The compression setting (on or off) did not matter with regard to eliminating the garbled characters.

    I am having the same issues. Is there any known solution for that?

    I realized that if I manually fix the UTF-8 encoding in the browser, it works fine.

    Is there a difference between page headers of cached pages and dynamic pages? Maybe the content type or encoding?

    I see no differences between http headers of cached pages and http headers of dynamic ones: both have the text/html UTF-8 content type and encoding 🙁

    Any more ideas?

    No, I don’t have any more ideas, sorry!

    What were you thinking about if the HTTP headers were different?

    I am quite lost but I would like to investigate a little bit in order to solve the problem.

    I guess this could be a good start point…

    The headers tell the browser how to interpret the content. I tried on my own server and the headers are different. I only use English characters for the most part so I haven’t seen any oddities. Here’s the headers:
    Uncached, served by WordPress:
    HTTP/1.0 200 OK
    X-Powered-By: PHP/4.4.7
    Content-Type: text/html; charset=UTF-8
    Date: Mon, 10 Dec 2007 11:52:15 GMT
    Server: LiteSpeed
    Connection: close

    Cached, served from a html file created by the cache:
    HTTP/1.0 200 OK
    Date: Mon, 10 Dec 2007 11:52:18 GMT
    Server: LiteSpeed
    Accept-Ranges: bytes
    Connection: close
    ETag: “9952-475d286f-eac51”
    Last-Modified: Mon, 10 Dec 2007 11:52:15 GMT
    Content-Type: text/html
    Content-Length: 9979
    Content-Encoding: gzip
    Vary: Accept-Encoding

    The cached version is missing the UTF-8 charset definition.
    You might be able to fix it using the “AddType” command in a .htaccess file. It would be great to finally fix this!

    I have same problem, i just put <meta http-equiv=”Content-Type” content=”text/html; charset=UTF-8″ />

    on the header of my theme and its ok.

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘special characters messed up’ is closed to new replies.