Support » Plugin: Amazon Associates Link Builder » Special characters instead of German Umlauts

  • Hennes79

    (@hennes79)


    After updating to WordPress 5.1.1–de_DE, when creating a new blog post all the German Umlauts (Ö; Ü ; Ä) are turned into special characters in the preview or when published. The editor view shows German Umlauts normally.

    Special characters happen for example if the blog post contains an image link copied from Amazon’s SiteStripe which has:
    target="_blank" and/or rel="noopener noreferrer" in it.

    Even worse, when linking internatlly to older posts on the same website target="_blank" and/or rel="noopener noreferrer" is added to older posts’ links resulting in special characters all over the website. Mmaking the text unreadable and looking unprofessional.

    e.g.:
    Ü becomes Ãœ
    Ö becomes Ö
    Ä becomes Ä

    This issue goes away when the “Amazon Associates Link Builder Version 1.9.2” is deactivated.

    What can I do to keep the issue from infecting my whole website and when is it going to be resolved?

    Thanks,
    Max

    • This topic was modified 8 months ago by Hennes79.
Viewing 6 replies - 1 through 6 (of 6 total)
  • I have the same problem with this Plugin!
    Is there no solution until yet?

    Doesn’t seem like it.

    @devs could we get an update that you’re working on resolving this problem?

    I have the same problem with spanish characters á é í ó ú ñ ¿ among others

    Any solution to this issue?

    takamu

    (@takamu)

    Hi, I have same problem in Japanese language.

    This is really known bug over 1 year but AALB Auther haven’t fixed yet.
    Strange characters like ’ in text

    A solution is …

    uncheck the “Remove rel=”noreferrer” for Amazon Affiliate Links from all posts” from plugin’s settings page.

    lola99

    (@lola99)

    I had the same problem and was really pulling my hairs but i found what is wrong with this plugin, you must do what Takamu said:

    Uncheck “Remove rel=”noreferrer”

    because for unknow reason it ads this:
    <!DOCTYPE html PUBLIC “-//W3C//DTD HTML 4.0 Transitional//EN” “http://www.w3.org/TR/REC-html40/loose.dtd”&gt;
    <html><body>

    just BEFORE the text of your article, its like creating a page inside the page and we end up with TWO <DOCTYPE>+<html>+<body>

    then, whatever charset you have on top of the page, in my case
    <meta charset=”UTF-8″>
    no longer exist in this second page inside your text, that’s why we end up with all this messy characters…

    You have to check the source file inside your browser because inside WP admin nothing shows up

    Hope this help !

    Hi guys, i found the solution! 🙂
    The error with the German Umlauts (Ö; Ü ; Ä) turned into special characters occures if you use the Amazon Associate Link Builder Plugin together with this snippet (placed in the functions.php), that’s supposed to prevent WordPress to add the noreferrer attribute to external links. That happend in WP 4.7.4.

    Old Snippet:
    // Note that this intentionally disables a tinyMCE security feature.
    // Use of this code is NOT recommended.
    add_filter(‘tiny_mce_before_init’,’tinymce_allow_unsafe_link_target’);
    function tinymce_allow_unsafe_link_target( $mceInit ) {
    $mceInit[‘allow_unsafe_link_target’]=true;
    return $mceInit;
    }

    But this snippet doesn’t work anymore since WP 5.x. So please this one instead:

    // Delets noreferrer from links if you save a post
    add_filter( ‘wp_targeted_link_rel’, ‘my_targeted_link_rel_remove_noreferrer’,999);
    function my_targeted_link_rel_remove_noreferrer( $rel_values ) {
    return preg_replace( ‘/noreferrer\s*/i’, ”, $rel_values );
    }

    After all use the Better Search & Replace Plugin to replace the referrer Attribut in the WP_Posts Table with nothing.

    On my site is now all ok and i can use the Amazon Associate Link Builder Plugin again with no problems.

    • This reply was modified 4 months, 4 weeks ago by The-Dude.
Viewing 6 replies - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.