Support » Plugin: WP Photo Album Plus » Special characters in HTML broken

Viewing 6 replies - 1 through 6 (of 6 total)
  • I wonder, if their is a connection to an other problem I now see.

    I changed existing description (to correct the above) and now get a message “Unbalanced tags in description” when I put in
    </br>
    or
    </br></br>

    These have been in the description and worked well previously. Also the problem does not show up in all descriptions ? Sorry but this is odd….

    Plugin Author Jacob N. Breetvelt

    (@opajaap)

    Are we talking about the album or the photo?

    Do you use the wp editor? (See Table IX-A11)

    The tag balance has nothing to do with the special char issue.
    Use <br /> for a linebreak (do not forget the space!)

    You can switch checking for tag balance off in Table IX-A2.

    Thanks,
    I realize that the balancing is a different story but I only now was hit by thi.

    Opes,… I normally use
    …..</br>…the latter got in but worked…

    I’ll have a check with the settings you suggest.

    Just for info: The special characters in my WP database got messed up after a server move and table unload/reload. Even the standard WP XML Export transform the specials into nasty strings.

    Thanks, that helped … did not know about these edit options.

    Back to the original problem: Use of the & # 228 ; (without the blanks (even in code it display correctly here) in an Album description still gives the ?

    For now I’ll use ä…. that works but to prevent future problems with e.g. DB unload/load, I wanted to use the symbolics…

    Note: In my first post the string “& # 228 ;” was meant… but translated correctly.

    Als “< br / >” was converted …sorry for that…

    Plugin Author Jacob N. Breetvelt

    (@opajaap)

    I did some tests. &# is already fatal, althoug i even convert & and # during the ajax action that transfers the data into a simple text token, so it must be somewhere else.

    There is nothing against using ä as long as you make sure the character set of the target db is utf-8.

    Hi Jaap. The tabel-field is utf8… The point is that I wanted to use & # … symbolics. This is about the Album-description.
    If i include this list:
    ‘ = & # 39 ;
    & = & # 38 ;
    : = & # 58 ;
    ” = & # 34 ; All these listed above work. However values higher than these do not and give the ? in s wiebertje…..
    The following do not display correctly:
    ë = & # 235 ;
    ö = & # 246 ;
    ü = & # 252 ;
    ï = & # 239 ;
    ä = & # 228 ;

    Note that i added blanks to have them show-up here….

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Special characters in HTML broken’ is closed to new replies.