Support » Plugin: SparkPost » Sparkpost doesn't use gravity forms mail credentials

  • Resolved Jarich Ypma

    (@jypma)


    This weekend I started using Sparkpost. Everything runs smooth except for one important thing: Gravity Forms notifications.

    The problem: The mail notification settings (sender name, sender mail, reply-to) configured in Gravity forms aren’t used by Sparkpost. When sending mail through sparkpost, the general settings from sparkpost tab are used.

    Is this intended behaviour, or is it possible to fix this?

    Sparkpost settings

    • From name:Info | ACME
    • From e-mail:info@example.com

    Gravity form notification

    What I get in test e-mails:

    What I want:

    Previously I used mandrill and this worked without problems. I hope this issue contributes to making the SparkPost plugin as good as a Mandrill.

    Regards,

    Jarich

Viewing 15 replies - 1 through 15 (of 22 total)
  • Plugin Contributor rajuru

    (@rajuru)

    It’s not intended and a fix to use filter instead of directly overriding is on the way.

    Plugin Contributor rajuru

    (@rajuru)

    A new version is released which uses filter to set sender name/email. If the gravity form’s filter priority is set properly (to be executed after ours) it should be working fine now. Please give it a try and let us know the result.

    Hi @rajuru,

    I’ve tested the update.

    The problem isn’t solved yet. I’ve got two problems now:
    1. The Gravity forms mail settings still aren’t used
    2. I’m sending two notifications on submitting a form. Only the first get’s delivered.

    Would you mind taking another look into this issue?

    Regards,

    Jarich

    Plugin Contributor rajuru

    (@rajuru)

    Thanks for your follow up.

    1. I can’t tell why it’s not working because I can’t see the plugin’s source code. Seems it’s not in the plugin repo (please provide link if it’s published somewhere else). If so, I could check how it’s setting the sender information.

    2. Almost same reply. But it may also be blocked/throttled in server level if you’re sending too many emails in short time. Check if the script generated two emails or not, if there is any error while generate the 2nd email.

    If you’ve related error, log etc. I would be happy to look into.

    Hi all,

    I have same kind of problem, but with Contact Form 7 plugin (https://wordpress.org/plugins/contact-form-7/). I previously used wpMandrill plugin and it worked without problems.

    My settings are following:

    Sparkpost settings

    From name: Info | Example
    From e-mail: info@domain1.tld

    Contact Form 7 form notification

    From name: Firstname Lastname
    From e-mail: noreply@domain2.tld
    To e-mail: info@domain1.tld
    Reply-to e-mail: firstname.lastname@example.tld

    What I get in test e-mails:

    Sender name: Info | Example
    Sender e-mail: info@domain1.tld
    To e-mail: info@domain1.tld
    Reply-to e-mail: info@domain1.tld
    Reply-to e-mail: firstname.lastname@example.tld
    (I can’t even automatically reply, because “Reply-To” header is added two times and that’s why Thunderbird ignores it)

    What I want:

    From name: Firstname Lastname
    From e-mail: noreply@domain2.tld
    To e-mail: info@domain1.tld
    Reply-to e-mail: firstname.lastname@example.tld

    I have added both domain1.tld and domain2.tld to Sending Domains list.

    Best regards,
    Henri

    Plugin Contributor rajuru

    (@rajuru)

    @perohen
    I’ll look into contact form 7 and get back to you. Just a question,

    (I can’t even automatically reply, because “Reply-To” header is added two times and that’s why Thunderbird ignores it)

    Is it same value for both ?

    Thanks

    @rajuru

    Thank you!

    Is it same value for both ?

    No. The value is not same.

    The first one is added by SparkPost plugin (mailer.class.php row 31):
    $phpmailer->AddReplyTo($options['from_email'], $options['from_name']);

    And the second one is added by Contact Form 7 using Additional Headers feature:
    Reply-To: [your-email]

    Plugin Contributor rajuru

    (@rajuru)

    Thanks for the clarification. That makes sense. I’m investigating these now.

    Plugin Contributor rajuru

    (@rajuru)

    @perohen

    What is the sender info in your mandrill plugin settings?

    @rajuru

    What is the sender info in your mandrill plugin settings?

    It is same as now:

    From name: My website’s name
    From e-mail: info@domain1.tld

    It is mainly used by WooCommerce, but the contact form should be able to use its own settings.

    Plugin Contributor rajuru

    (@rajuru)

    @perohen
    Thanks for your info. I wanted to verify your contact form settings are not same as mandrill settings.

    In my test, I’ve found contact form is not using it’s settings rather the settings in mandrill plugin is used.

    Any update on this? I’d be happy to provide access to a staging server with Gravity Forms installed if helpful. I’m moving over from Mandrill and improper GF name/email handling would be a dealbreaker.

    Plugin Contributor rajuru

    (@rajuru)

    Hello
    I just wanted to follow up that a version of the plugin is released that no longer makes it mandatory to enter from name/email; these are now optional field and will sender name/value only if value is provided.

    Please try that version if let us know if it works of you. Any other suggestions/feedback is welcome.

    Just updated. Interestingly HTTP API and SMTP 587 do not preserve the reply-to field, only SMTP 2525 does. Is that intentional or a bug?

    Plugin Contributor rajuru

    (@rajuru)

    If 2525 adds Reply-To that’s a bug because as of latest version we’re not setting it.

Viewing 15 replies - 1 through 15 (of 22 total)
  • The topic ‘Sparkpost doesn't use gravity forms mail credentials’ is closed to new replies.