Support » Plugin: WooCommerce » span tag in woocomerce

  • Resolved martydev

    (@martydev)


    Hello. Help me please –

    I have product with variation “Standart License”
    In single product on front all ok, but when I buy product, in My account – downloads I see – “Basket of grapes TEST<span> – </span>Standart License” – https://i.imgur.com/ZbEzIry.jpg and in checkout – https://i.imgur.com/IsN5psU.jpeg How fix it…?

    PS I don’t make any customizations… I checked attributes – span tag not exist

    it is not title, it is symbol ‘-‘ https://i.imgur.com/WKVE9xF.png between title and attribute

    I talked with my template support, they investigated and says – it is in woocomerce

    The page I need help with: [log in to see the link]

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Support gabrielfuentes

    (@gabrielfuentes)

    Hi there 👋

    This kind of problem is usually caused by a conflict with your theme or with another plugin.
     
    The best way to determine this is to:

    • Temporarily switch your theme to Storefront
    • Disable all plugins except for WooCommerce
    • Repeat the action that is causing the problem

    If you’re not seeing the same problem after completing the conflict test, then you know the problem was with the plugins and/or theme you deactivated. To figure out which plugin is causing the problem, reactivate your other plugins one by one, testing after each, until you find the one causing conflict. You can find a more detailed explanation on how to do a conflict test here.

    Before you start

    1. First, please make sure you have a good backup in place of your full site and database. Most hosting companies have this included in the subscription, but you could also consider using a service like Jetpack. If something goes wrong, it’s nice to know that you can restore your site.
    2. Second, I would suggest installing a plugin called Health Check & Troubleshooting. This is a plugin developed by the WordPress community and it allows you to disable plugins without affecting your current site visitors.

    I hope that helps!

    Thread Starter martydev

    (@martydev)

    no,

    1) I sweetch template and turn of plugind
    2) I use minimum plugins (elementor + hello elementor templates) – and this pare work well on other sites

    Thread Starter martydev

    (@martydev)

    @gabrielfuentes in file plugins/woocommerce/templates/myaccount/downloads.php I see action:

    
    	<?php do_action( 'woocommerce_available_downloads', $downloads ); ?>
    

    where this action formed / built? I want to see how this strict is built – https://i.imgur.com/4JOWYFl.png

    Thread Starter martydev

    (@martydev)

    can anyone suggest?

    Plugin Support Ena P (a11n)

    (@drwpcom)

    Hi @martydev. Sorry that we missed your last response. The fact that the HTML is not rendering means it’s hard-coded in some way. I can’t replicate this issue on my site with downloadable products using Storefront and only WooCommerce being active.

    While WooCommerce has its own default preferred style, that is overridden by the styling of the theme you use and of the page builder, Elementor in this case. I recommend checking your Elementor templates and the email templates if you’ve customized them in your theme.

Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.