Support » Plugins » Spam Karma – blocking EVERYTHING???

  • I recently installed Spam Karma, but my problem is that it deletes EVERY SINGLE COMMENT that is placed, no matter who the commenter is or what the comments are about – people who have previously commented before even get blocked, no comments are allowed through..
    I’ve tried all the different settings in the Options – Spam Karma page, and tried everything, but there’s no difference.
    In the digest thing they email you when a comment has been deleted, on some posts it’ll even say “URL is in blacklist” or something, which I know shouldn’t be, and when I check that blacklist url it isn’t there, so what is blocking my friends and others from commenting?
    Because of this, I’ve deactivated SpamKarma because I can’t get any comments, but now I’m flooded with spam everyday, and I’m sick of deleting it all everyday. Does anyone have any ideas? Please help, thanks.

Viewing 15 replies - 1 through 15 (of 31 total)
  • Moderator James Huff

    (@macmanx)

    Volunteer Moderator 🚀

    Reactivate Spam Karma (make sure you have v1.20) and reset the blacklist.

    i’m using v1.5 though.. doesn’t spam karma work for 1.5? how do i reset the blacklist?

    Moderator James Huff

    (@macmanx)

    Volunteer Moderator 🚀

    I’m sorry, I meant make sure that you have Spam Karma v1.20. To reset the blacklist, scroll down through SK’s options until you find a button that says “Reset Blacklist”.

    Uh.. I have Spam Karma 1.20 alpha 2? I have reactivated and deactivated it, but I’m still having problems with Spam Karma not letting anyone comment. >.<” Any other ideas?

    I’m having the same problem… most of my friends don’t bother commenting anymore because they just keep getting blocked, or it goes to the moderator bit, and I’m not geting any notification that there are comments to be moderated. Did anyone come up with some solutions to this?

    If I’m not mistaken, that version of SK is only for the next release of WordPress (1.5.1).

    Moderator James Huff

    (@macmanx)

    Volunteer Moderator 🚀

    davincim, Spam Karma v1.20 is for WP v1.5. Spam Karma v2.0 is for WP v1.5.1.

    Sproke, try resetting your blacklist.

    Thanks, I pushed the ‘reset’ button, and this is what came up:

    ” Could not delete, used ‘truncate’.
    Updating Blacklist Table Structure.
    Emptied Blacklist. Deleted: 0 entry”

    Is that what’s meant to happen?

    Also, I tried to “remove IP ban” of my friends IP, and it said that the IP wasn’t in the list… is there anyway that I can tell it to accept certain IPS?

    Thanks for your help!

    Hey everyone. I’ve now encouted a new problem. SK seems to be blocking out all of my friends, but letting spam in! I’m so upset, because I don’t know why it’s not working! Can someone please help? I don’t want to turn off commenting, but at this rate, I’m going to have to. PLEASE HELP!! Thanks so much!!

    Moderator James Huff

    (@macmanx)

    Volunteer Moderator 🚀

    Contact Spam Karma’s developer.

    Did you see:
    http://www.unknowngenius.com/blog/wordpress/spam-karma/false-positives/
    ?

    Sproke, no that’s not meant to happen – if it deleted 0 entries, that means the blacklist was empty… hence the spam coming through. Are you sure everything is installed correctly?

    As for your friends, are they AOL users? Or other users behind a proxy? This will cause the secret code embedded in the comment form to be incorrect upon submission, leading to comment deletion. The other problem is that your friends could be on a Realtime Blacklist server, such as SpamHaus. Turn off the RBL check in your options.

    Spam Karma 2 has whitelisting options (i.e. automatically approving your friends) but SK1.20 does not.

    Kay, I’ve upgraded to 1.20alpha now, but there still seems to be a problem. I’m gonna have a fiddle with things, hopfully I can fix them.

    Everytime I try to comment when I’m not logged into my WP, it comes up as ‘No Input Specified’ when I post it. I am soooo not happy.

    And my dumb hosting server can’t install myphpadmin properly, so I can’t even access the damn thing to backup and upgrade.

    Blogging is so difficult these days 🙁

    Mark (podz)

    (@podz)

    Support Maven

    angsuman
    You are risking your posts being DELETED.
    STOP IT.

    Okay, now it’s doing something really crazy.

    I have no normal Spam, and no Trackback spam, which is GREAT!

    But, it is not letting any of my friends through, and telling me that they’ve been moderated or eaten. But then, I go to the comments section, where you can veiw and delete them, and the comments are sitting there, happy as larry. They have not been deleted. BUT they are not showing up under the posts. They’re just sitting in the comments page.

    And also, what’s the deal with the ‘blacklist maintence’ part? It has all of my friends IP’s there, with little tick boxes beside them, with this message that says

    “These entries were automatically added to the blacklist, please edit as necessary, uncheck the ones you do not want to keep and submit the form to make the ban permanent”

    What does this mean? Do I uncheck them so that they do not go into the black list, or do I uncheck them so that they do go into the blacklist? This message worded very badly! *spanks SKcreators hand*

Viewing 15 replies - 1 through 15 (of 31 total)
  • The topic ‘Spam Karma – blocking EVERYTHING???’ is closed to new replies.