Support » Plugin: Honeypot for Contact Form 7 » Spam Emails going through despite honeypot field being filled

  • sandman47

    (@sandman47)


    Screenshot:

    https://imgur.com/a/Q6D1Fwv (click to expand screenshots)

    I have a honeypot field in one of my forms, using a [honeypot website] tag.

    Bots are filling the honeypot out and the mail is still being sent. Did I configure something wrong?

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author Ryan

    (@nocean)

    Hi @sandman47 – a couple questions:

    1. What versions of WordPress, CF7 and CF7 Honeypot are you using?

    2. What method of email capture are you using? Is that CFDB7?

    Thread Starter sandman47

    (@sandman47)

    Hello,

    WordPress Version: 5.8.1
    CF7: 5.4.2
    Honeypot for CF7: 2.1

    The mail capture is using Flamingo, V 2.2.2.

    All software/plugins are fully updated.

    Thank you

    Plugin Author Ryan

    (@nocean)

    Very strange. Is there anything in your setup that could be disabling or modifying CF7’s spam system? I.e. any custom code or a 3rd party plugin that might be modifying the way CF7 behaves?

    Basically, CF7 has a built-in way of flagging form submissions it views as spam. Plugins like Honeypot (or captchas, math questions, etc.) can then tap into that functionality and use their various logic (i.e. a filled in honeypot field) to determine whether that spam flag should be set.

    When the flag gets set, the form submission isn’t emailed out, the user is displayed the “Submission was referred to as spam” message from the form’s settings, and in Flamingo the submission is saved to the “Spam” tab of the Inbound Messages.

    On all the sites I’ve tested Honeypot on, this happens as expected. But for some reason this doesn’t appear to be happening on your install. If you’re able to send me a link to the contact form so I can check the HTML generated in the form (ryan at nocean dot ca), I’d be happy to do so.

Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.