Support » Fixing WordPress » Spaces removed after punctuation

  • I’m using the latest Atahualpa release (3.6.7) on the latest WP release for my client http://www.miningtheunconscious.org.

    Despite all looking well in both the code and visual editor, the live site is removing or not displaying the spaces following commas, ampersands and so on, including in the navigation bar and page title (words that are typed in, not pasted from client copy).

    I can’t figure out why or how to fix it (for instance, retyping copy directly into the code view – not pasting; attempting to add extra spaces, etc..

    As ever, the code view in WP definitely doesn’t show all code. I feel hamstrung! Anyone else encounter this and/or know the fix for it? I’m also checking at the ATahualpa site.

Viewing 15 replies - 1 through 15 (of 22 total)
  • Same thing here. Also, my tag cloud widget isn’t working correctly. You can see it on my site.

    What a pain – and no other replies – I would think this would be a pretty major issue… Tried to sign up for the Atahualpa forums but couldn’t get any access to actually POST anything.

    No idea unfortunatly, but for the time being, you can simply go into code view and add   after each comma. Very tedious but works.

    You can also copy all text into a word processor such as Microsoft Word or Notepad++, and use the search & replace all by replacing , with ,  then pasting it back, in code view saving some time & hassle.

    Yeah, exactly, I’m not remotely interested in coding hard spaces through a whole site, AND this will NOT be useful for the Atahualpa footer text and any other automatically generated content. Could do the search and replace, but jeez, this is a really popular theme, and flexible, and I would THINK they would either know the fix for this new release or get on it really fast – it’s a really bad one! Doesn’t render the site useless, but sure makes the designer look like di*k.

    I have managed to post in a hopefully appropriate thread over at Bytesforall and will update here, nrepair, if I get any joy from them (or otherwise).

    Oh, and nrepair, I was just wondering, too, what your site is?

    Moderator kmessinger

    (@kmessinger)


    I use Atahualpa and have no problem. It is not them or WordPress.

    First, if anyone is pasting from word forget it. Second, disable all plugins, switch to the twentyten theme. This will eliminate theme, plugin conflicts. Then add each back until it breaks.

    If there is a problem with the editor, 99.99% of the time it is a javascript error. Try the above and report back with URL’s.

    kmessinger, it is indeed an issue with the actual theme, see below.

    edit css.php and change lines 2944-2951 from

    if ( $bfa_ata['css_compress'] == "Yes" AND
    !( isset($bfa_ata_debug) AND $bfa_ata['allow_debug'] == "Yes" ) ) {
    	ob_end_flush();
    }
    if ( isset($bfa_ata_preview) OR $bfa_ata['css_external'] == "Inline" OR
    ( isset($bfa_ata_debug) AND $bfa_ata['allow_debug'] == "Yes" ) ) {
    	echo "</style>\n";
    }

    to

    if ( $bfa_ata['css_compress'] == "Yes" AND
    !($bfa_ata_debug==1 AND $bfa_ata['allow_debug'] == "Yes" ) ) {
    	ob_end_flush();
    }
    if ( isset($bfa_ata_preview) OR $bfa_ata['css_external'] == "Inline" OR
    ($bfa_ata_debug==1 AND $bfa_ata['allow_debug'] == "Yes" ) ) {
    	echo "</style>\n";
    }

    Taken from: http://forum.bytesforall.com/showthread.php?t=14143

    are you using some sort of compression option?

    your html code is all in one very long line…

    this looks related:
    http://forum.bytesforall.com/showthread.php?t=14143

    (however, i didn’t follow the thread to see if it offers a solution …)

    thanks for the notes, chjmdm & alchymyth, I will follow that up and see if the CSS fixes it. I thought of looking through their code, but honestly, the idea of finding the one line that might be causing this was not really within my abilities for working hours, ha.

    And for what it’s worth, I either retype, or run through a .txt file in Dreamweaver or Notepad – and clean up there – any Word copy I get from clients. And this was broken in this manner from step 1 install, with only clean WP install + new activation of theme and minimal text (you could tell, because navigation titled “SOMETHING & SOMETHING ELSE” would come out looking like “SOMETHING &SOMETHINGELSE”).

    Very hopeful this will cure it, and will also see what comes back from the BFA forum – thanks all!

    Moderator kmessinger

    (@kmessinger)


    The bfa forum has this note added to 3.6.7

    UPDATE: Atahualpa 3.6.7 with working custom widget areas, everything up to post #7 taken care of

    Since the issue above was post 1, downloading and installing the latest build should fix the problem.

    And to whomever – thanks for the attempt at editing. I appreciate the frustration we all feel from time to time.

    SUCCESS! And one possibly useful final note:

    I followed the fix instructions in the css.php file (above and from original thread in bfa forum), and got bad and weird results – namely removed all the styles! – and when I switched it back (I combed over my syntax very carefully and tried this all several times, both via DreamWeaver upload and via the editor in WP), the site displayed a blank page. Don’t know if there’s some issue I’m missing on my local end, but it just wasn’t working.

    So, I downloaded the file offered at the end of that BFA post – css.php.zip, and first erased then replaced the css.php file with the new one, no opening or editing, and all is VERY WELL now. Use the repaired file they’re offering if you have any issues doing the simple css test repair.

    Thanks to all for your input.

    There are THREE bugs in Altahualpa 3.6.7 – you may want to look at these two pages and fix them all…

    http://alantait.net/atahualpa/atahualpa-easy-header-fix-downloads/
    http://alantait.net/2011/06/09/atahualpa-easy-header-fix/

    ALL sites should install BUGFIX 367-01 and BUGFIX 367-02

    Single sites may install the EASY HEADER FIX or BUGFIX 367-03 but not both.

    MultiSites and Multi Networks should install the EASY HEADER FIX and NOT install BUGFIX 367-03

    This is helpful (if I can figure out how to make the changes), but here is the strange thing.

    I called my hosting company last night and they reverted my site back to where it was before I updated to Atahualpa’s new version. It took care of the fact that my favicon had reverted to the original that came w/ atahualpa, but the punctuation issues remain.

    Why would that be? I am going to see if they can make it go away again by going back further, but this makes not sense.

    Any ideas as to why this would not have fixed it?

    I have had this problem on 3 atahualpa sites. Today I tried the fix editing the css.php file and it was both easy and successful.

    Oddly, the method that worked for someone above replacing the file with downloadable one didn’t work for me yet she’d had problems editing the existing file.

    So it looks like both methods can work. Really pleased to have this sorted out.

Viewing 15 replies - 1 through 15 (of 22 total)
  • The topic ‘Spaces removed after punctuation’ is closed to new replies.