Support » Plugin: ezPHP for WordPress » space added to between opening angle bracket and ?php in posts/pages

  • Resolved CoolDavidoff

    (@cooldavidoff)


    Pam’s almost five years old thread here https://wordpress.org/support/topic/space-added-to-between-opening-angle-bracket-and-in-pages/
    (locked) is current as ever, so it’s unfortunate for the reputation of the plugin author team and their company websharks that this hasn’t even been attempted to be solved.
    And so, an otherwise GREAT plugin (like all from websharks), this one unfortunately is unusable, except for those who know how to solve such problem themselves, maybe.

    Being s2member PRO customer too, I have now filed a ticket in their forum there too, because ezphp is still being recommended inside s2member PRO in order to achieve customizations that aren’t possible or sensible with the s2m shortcodes themselves.

    So, again: When a POST OR PAGE gets SAVED, some kind of WORDRESS FILTER adds a space character between < and the ?php, which prevents code execution.
    In WIDGETS however it does work (for us).

    So I went into functions.php myself 🙂 searching for any and all filters that affect things like
    the_content
    comment_text
    widget_text_content
    term_description
    the_excerpt

    …and digged into the code myself 🙂 to make sure nothing adds a space into
    the_content

    Well, you guessed it, being no coder… it hasn’t helped. 🙁

    The plugin authors here all are mega great coders.
    So I guess, once ONE of them gets down here to this wordpress forum and his hands dirty (only if the keyboard is dirty), then this will be solved in a flash, huh?

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Author Raam Dev

    (@raamdev)

    The issue is not with the the ezPHP plugin. It’s an issue with your theme or with one of the other plugins you’re running.

    Here’s a test of both the regular PHP tags and the shortcode PHP tags using the latest version of ezPHP and the latest version of WordPress:

    https://raam.wpsharks.net/testing-ezphp/

    Please disable all other plugins and temporarily switch to the default WordPress theme to test ezPHP in a clean WordPress environment. Then re-enable your plugins/theme one-by-one and re-test until you find the plugin/theme causing the problem.

    Also, please make sure you’re not using a visual editor of any type on Posts/Pages that have regular PHP tags (<?php). If you must use the visual editor, you should use the shortcode version ([php][/php]).

    Thread Starter CoolDavidoff

    (@cooldavidoff)

    “The issue is not with the the ezPHP plugin”

    No one in this nor in any of the other threads suggested so, Raam.
    At the very least, Pam (5ys? ago) and myself, wrote clearly “WORDPRESS causes…”

    Either way, we ALSO wrote, this is NOT theme and NOT plugin related, no. See Pam’s thread please. In blank installs it’s the same.

    I clearly wrote “some WORDPRESS FILTER…” seems to be messing up your plugin. A filter that WORDPRESS seems to have introduced just before Pam started her thread, both here, and in your (old) forum @websharks, thus some 4 to 5 ys ago.

    Now if, based on your “inhouse tests” you assume that not wordpress but some hosting parameter may cause this, I would instantly agree “Yes, possible!”

    Yet again, YOUR team of plugin authors and ingenious programmers clearly has the skill to pinpoint WHICH hosting parameter is at fault then?

    As said, I thought I found it and I asked the new hosting guys to enable “php eval()” which Jason’s server scanner script marks as important.
    Unfortunately however it cannot be THIS parameter, or not this one ALONE.

    As for your “disable the visual editor”, again, both Pam and I have never even seen the visual editor, we disabled it outright.

    And I never want to see this again “Please disable all other plugins” as we PURCHASED several of webshark’s plugins that REQUIRE to be enabled – hey, otherwise what’s the membership-only access for??

    So again, leaving ONLY YOUR PLUGINS enabled, and the standard theme, ezphp doesn’t work still.
    And again, YOUR team of plugin authors and ingenious programmers clearly has the skill to pinpoint WHICH hosting parameter is at fault IF this is not caused by wordpress but by hosting parameters??

    (which I agreed, seems likely now)

    Thread Starter CoolDavidoff

    (@cooldavidoff)

    Oh, and looking at your “test” page, quickly two tips:

    1) IF you “running on the latest version of WordPress.” then it would be wise ANYWAY to update your plugin here, because wordpress “warns” of it like in “This plugin hasn’t been updated since the last three core wordpress upgrades and it may no longer work”.

    2) Your testpage either is incomplete or irrelevant, Raam:
    Your screenshot shows clearly that you haven’t even SAVED that “test” page, but bot Pam and myself wrote clearly “When a page or post gets SAVED, a space character is added…”

    😉

    Plugin Author Raam Dev

    (@raamdev)

    I’m not sure how you think that you can tell the Post hasn’t been saved by looking at the screenshot, but it has, and you’re looking at the post when you’re looking at the page.

    I won’t reply to the other points because quite frankly it’s not nice to be nasty on the Internet and at this point we’d be going in circles.

    ezPHP has been tested on the latest version of a WordPress and saving a post in Text Mode with PHP tags does not garble the PHP tags. It does not add any spaces.

    Thank you for your feedback.

    Thread Starter CoolDavidoff

    (@cooldavidoff)

    Okay I do reply to your first point then: Easy. When wordpress has saved a page I always get to see “Page updated. View page”, like everyone does. That’s not to be seen on your screenshot.

    And quite frankly, that it is not to be seen is not my fault, nor that no one has replied to the questions here, right? I am more than surprised how you found anything here “nasty”, maybe you (wrongly) took my praise as irony(?) but it isn’t Raam! My “YOUR team of plugin authors and ingenious programmers clearly has the skill to pinpoint WHICH hosting parameter is at fault then?” is both honest and honoring: Remember that I am one of those that has promoted websharks ever since I purchased the first product, and so, quite frankly, your response here now I find nasty, unjustified, misplaced, unprofessional.

    So let’s forget that, and back to basics: what I asked, Pam, and all the ones in her old thread both here and on websharks’ site:

    What can cause the space to be added, if neither other plugins, nor themes, nor wordpress filters are at fault? Is my guess “hosting parameters” really so way off? I am wondering what else I could look into. I can’t code, I am the end user, I can only make guesses and try things – which I have done extensively but couldn’t figure out for ezphp.

    Websharks has a top free plugin with ezphp that could draw thousands of additional customers to your other top plugins like s2member PRO, CommentMail PRO, etc – just not if all support threads here go unanswered, or worse, labeled “nasty”. No one is nasty here. We all seek to get things to work. And websharks has some of the best plugins ever created!

    Plugin Author Raam Dev

    (@raamdev)

    You are correct that I misunderstood the tone of your post and for that I apologize.

    The “Post updated” message appears above the post title and since my screenshot did not include anything above the title, you did not see that message. I didn’t think it was necessary to include since viewing the post for which I was taking the screenshot should be evidence enough that I saved it (how else would you be able to view it?).

    I do not know of any server or hosting configuration that would add spaces to PHP tags. If it’s happening with the default WP theme and no other plugins then I would suspect that your hosting company might have their own MU plugin or some other “feature” that is trying to strip out PHP tags for security reasons. I don’t know of any PHP or server configuration that would modify PHP tags in that way.

    Thank you for your patience and again I apologize for misunderstanding.

    Thread Starter CoolDavidoff

    (@cooldavidoff)

    Agreed. I am convinced there is an ezy solution to get ezphp to work for EVERYONE, whether they use it for their s2member Pro sites, CommentMail Pro templates, or even for a site that has no meaningful other plugins.

    Could maybe you as experienced coder give all us users and customers who cannot code, the code (likely no more than 3 to 5 lines) that we can put in our functions.php, and it will “cleanse” the POST and PAGE content from the space character whenever it gets added between
    <
    and
    ?php
    by either a wordpress filter, hosting php version, or whatever ?


    “should be evidence enough that I saved it (how else would you be able to view it?).”
    ez, Raam, happy to explain that: You didn’t show us the frontend post view. Your screenshot shows us the post during editing: See the wp admin bar on the left.

    Once SAVED, a post/page has the “updated..view post/page” link at the top, indeed: At the height you see in this combined screenshot: https://www.dropbox.com/s/sp46i79eexbp8xi/how-wordpress-saves-a-post-or-page.png?dl=0

    No one can know that your wordpress would post that “view update” link even hiigher up?, and why? In my wordpress anything higher up would be… the address bar. 🙂

    Isn’t important though, was just to answer your question.

    My question is: Can you give us desperate users a couple of lines code for the functions.php?

    Plugin Author Raam Dev

    (@raamdev)

    @cooldavidoff If you could provide me with a list of steps to reproduce the issue in a clean WordPress environment so that I can reproduce the issue on my personal test site, then I might have some suggestions. 🙂

    Thread Starter CoolDavidoff

    (@cooldavidoff)

    Thank you, I will try to do that, only right now I can’t, maybe another user can do it quicker…

    But why did you, or someone else?, mark this as resolved when the evidence of countless users clearly documents here that nothing is resolved?

    We shouldn’t mislead other users I feel, just for the benefit of looking “polished”.

    I know of the terrible wordpress habit to auto-close threads just because they prefer their own “akismet plugin” over my 100% successful SPAM protection WITHOUT a plugin… – but marking a thread as resolved where it isn’t resolved is a whole different matter. Why do they suddenly do that??

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘space added to between opening angle bracket and ?php in posts/pages’ is closed to new replies.