Support » Plugin: Image Source Control » Sources list does not include links to all pages

  • Resolved lebensessenz

    (@lebensessenz)


    Hello Thomas!
    Thank you very much for this very helpful plugin! But I do have an issue: In the sources list. It does not show the pages of all my images. And I had to use the “all”-version because the normal code only showed the sources of about 20 images…
    See this: http://www.lebens-essenz.com/impressum/bildquellen/
    I saw that you posted the issue in the English manual (if i got that right), but I did not understand what I am supposed to do to repair it.
    Thanks again for the plugin, which is a great help!
    Saskia

Viewing 12 replies - 1 through 12 (of 12 total)
  • Plugin Author Thomas M

    (@webzunft)

    Hi Saskia,

    thanks for reaching out.

    You mean that for an entry like “538 | Citrus fresh” there is no entry in the “Angezeigt unter” column but you have this on a page? (I didn’t check)

    Images and posts are normally associated by the plugin when the post is updated. Could you please update one of the posts in question and see if that works?

    Thanks
    Thomas

    Hi Thomas,

    danke! Yep, that’s what I meant. And updating the post did the trick. So, I’ll be updating quite a few now ;). As far as I see that has to be done manually for each post.

    Thank you!

    Something else: I would like to either show the sources per 25 a page. The code in your manual didn’t work for me. Another possibility to show less entries would be to filter all images from the same source (in my case: all mine as author, all with copyright Young Living etc. pp). Any suggestions? Thank you very much!

    Best,

    Saskia

    Plugin Author Thomas M

    (@webzunft)

    Hi Saskia,

    well, it should update automatically, but as we see on your page, it didn’t work.

    Could you please post the code as you used it to limit the sources per page here? It happened once that there was just a typo.

    The latest version is running on my blog on http://www.gruenderstory.de/bilderverzeichnis/ and as you can see, the pagination works.

    Thomas

    Hi Thomas! I suppose it will work for all new posts. Here ist the code I used to try to limit the sources per page:

    [isc_list_all per_page="25"][

    That one is obviously wrong with a [ too much… I found it here: https://webgilde.com/de/image-source-control/image-source-control-anleitung/

    But the code in the English version doesn’t work eiter:

    [isc_list_all per_page="25"]

    And, yesterday I updated a lot of my posts and they appeared okay in the sources list. Today, a lot of them were gone again!

    Oh, and yes, I did clear the cache before trying again…

    It would be really sad not to be able to use that plugin – it is such a great idea…

    Saskia

    • This reply was modified 3 years, 6 months ago by lebensessenz.
    • This reply was modified 3 years, 6 months ago by lebensessenz.
    Plugin Author Thomas M

    (@webzunft)

    Hi Saskia,

    thanks for making me aware of the typo.

    Unfortunately, the code also looks right to me and when I copy it to my own blog, it works as expected.

    So in your case, the pagination doesn’t work but the rest does?

    I am also irritated about the pages not stucking. It looks like there is something more wrong on your site.

    Right now, I can only suggest to turn off one other plugin after the other to see which one breaks it. Maybe even switching to a default theme would help to determine if your theme does something. Only when I know when the conflict happens, I can try to reproduce it. Else, I am in the dark here.

    Sorry for not having a simpler suggestion.

    Thomas

    Hi Thomas,

    I found a mistake I made: I entered the right code in the code-view of WordPress and for some reason it didn’t change anythig in the wysiwyg-view. So, I entered the code in both views and now it works. Well, partially. Because in the version with pagination I am only shown the entries with a correct link to the page the image is from. All the others do not appear. I’ll let you know what happens after updating all posts.

    And thank you so much for the support.

    Saskia

    Plugin Author Thomas M

    (@webzunft)

    Hi Saskia,

    I am glad it works.

    Did you add the included=all attribute? With this option set, it will also show images not attached to a post.

    [isc_list_all per_page="25" included="all"]

    Thomas

    That did the trick! Thank you!

    Saskia

    Plugin Author Thomas M

    (@webzunft)

    Now I am relieved 🙂

    • This reply was modified 3 years, 6 months ago by Thomas M. Reason: typo

    Hi Thomas,

    sorry, but I have to bother you again. I had some time today and tried to update my pages and posts in order to make them appear correctly on the image source page. Unfortunately, nothing happens. Even after clearing the cache. Is there any suggestion what I can do to show a complete list including the entry in “Angezeigt unter”?

    Thank you!

    Saskia

    Plugin Author Thomas M

    (@webzunft)

    Hi Saskia,

    I think I am at a loss here and would need to see this live, including the backend.

    Would that be possible? You can send us an email via https://webgilde.com/de/kontakt/ to get in direct contact.

    Thanks
    Thomas

    Thank you for your help, Thomas. The plugin is working perfectly well now.
    Everyone should have this plugin :).
    Regards,
    Saskia

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘Sources list does not include links to all pages’ is closed to new replies.