The Support Forums will be in read-only mode for a scheduled maintenance window on 01 September 2016 14:00 UTC - 20:00 UTC. More information.

MyCurator Content Curation
[resolved] Source It not operating properly (6 posts)

  1. adoggett
    Posted 3 years ago #


    I am loving this plugin! Thank you.

    I am having a problem with Source It: I am using Chrome and I dragged the Bookmarklet to the Bookmark bar. I have tried to Source several websites but each time Source It opens a new window and I get a 404 Not Found page from my own website. Please help!

    Here's an example of an attempt to Source It (happens on every page I've tried):

    Also, is there no way to add sources to Topics in any way other than Source It? I already have many RSS feeds that I could just copy and paste into each appropriate Topic, but I do not see a place to do this. I figured a solution would be to simply pull up the RSS feed itself in my browser and use Source It... but then I would need Source It working... :)

    Thank you for your help,


  2. mtilly
    Plugin Author

    Posted 3 years ago #

    Go to the Links menu in the dashboard and choose Source Quick Add. You can add in any sources through copy and paste this way. In the meantime we will look into the source it problem.

  3. mtilly
    Plugin Author

    Posted 3 years ago #

    In checking out the link you attached, I do see that it goes to your 404 page. It should bring up the login screen for someone who is not logged in. If I strip off everything after the sourceit.php (the query arguments) I do get to the login screen as expected.

    When I used the full url in my browser, I saw an error message show up briefly before the 404 page. When I used the shorter URL I was able to capture the error message:

    Warning: Missing argument 2 for wpdb::prepare(), called in /home/thomwarp/public_html/trendymax.com/wp-content/themes/gonzo/includes/widget_areas.php on line 154 and defined in /home/thomwarp/public_html/trendymax.com/wp-includes/wp-db.php on line 990

    This looks like the same error message I see briefly with the full URL.

    I think your theme is capturing the incoming call to Source It and redirecting it to the 404 Not Found page. It could also be happening with some redirects in your .htaccess file, or maybe a security plugin that captures 'unknown' calls or calls directly to wp-content pages.

    If you need help with exploring this, please contact us through the Contact Us menu item on our site

  4. adoggett
    Posted 3 years ago #

    Thanks for the Links -> Source Quick Add direction! Exactly what I needed. I sent you a message through your contact form for the Source It problem.

  5. mtilly
    Plugin Author

    Posted 3 years ago #

    After working offline, we found that the host had implemented extra security for this site. That security was blocking the Source It tool from starting up.

    If you get a 404 error on Source It or Get It, then check with your host and send them the url at the top of the little window. They should be able to tell why they are blocking that url from completing.

  6. mtilly
    Plugin Author

    Posted 3 years ago #

    As a work around, while waiting for your hosting company to respond, you can do the following:

    1. Right click on your Source It (or Get It) bookmark and choose Edit.
    2. Click on the URL field and scroll to the end until you find (l.href)
    3. Replace it with (l.host+l.pathname)
    4. Click Save

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • MyCurator Content Curation
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic