Support » Fixing WordPress » Source Code Has Something Strange

  • Resolved Rita33


    I have started having some trouble with the preview of my links on Facebook and Hootsuite. I thought it was a Hootsuite problem but they said it was not that there was something in my source code:
    ” there is a character within your page source code ” -�” (in case this does not appear within your email properly, the character looks like a black diamond with a white question mark within it). The HootSuite thumbnail scraper appears to be unable to process this particular character and is copying all the source code that follows it.”

    The only thing I have changed recently was adding a plugin which I deleted but there is still an issue. When I put a link on Facebook this is what the preview looks like, instead of the text:

    -�\u00ad\u0600-\u0604\u070f\u17b4\u17b5\u200c-\u200f\u2028-\u202f\u2060-\u206f\ufeff\ufff0-\uffff]/g,gap,indent,meta={“\b”:”\b”,” “:”\t”,” “:”\n”,””:”\f”,” “:”\r”,'”‘:’\”‘,”\”:”\\”},rep;typeof JSON.stringify!=”function”&&(JSON.stringify=function(e,t,n){var r;gap=””,indent=””;if(typeof n==”number”)f…

    Does anyone have any idea where I would find this code and how to fix the problem. I have already searched my theme files and can’t locate it. My site

Viewing 3 replies - 1 through 3 (of 3 total)
  • The plugin’s the issue. I can’t tell you exactly what it says, but the plugin you’re using is outdated (from what I can tell) or possibly conflicting with another facebook plugin. I’d recommend using the official Facebook plugin.

    Also if you can’t see any plugins it would (obviously) conflict with and the plugin claims to work with your version of WordPress you should contact the plugin Developer.

    I also have this issue since a few days.

    I’ve searched the code on Google and get pages of posts with the same error – some from Facebook, some not.

    @the Dev. “The plugin’s the issue” < Which Plugin? Are you saying that it is a sharing plugin that is corrupting the code? I am using “Twitter Facebook Social Share” – I just tried disabling it and manually posted to FB and the same issue occurred.

    @rita33 I also had problems with Hootsuite – had to manually edit the snippet (as I’ve been doing with FB – I’ve seen FB pages with each post corrupt as they are autofeeding content in). On Google Plus it takes the categories listed at the top of the page as the snippet (for some strange reason – but that’s another story!)

    I have the following social plugins installed, but all of these are NOT currently activated…

    Social Share Buttons
    Social Share
    Slick Social Share Buttons
    Easy Facebook Like Button
    Facebook Subscriber Widget
    My Twitter Widget
    New Twitter Button
    Really Simple Twitter Feed Widget
    Rimons Twitter Widget
    Show Twitter Followers
    Twitter for WordPress
    Twitter Tools
    Twitter Widget
    Twitter Widget Pro
    WP Twitter Sidebar

    These plugins are active

    Twitter Facebook Social Share
    Advanced Twitter Profile Widget
    Social Login – not sharing but logging in…
    Slideshare Embeds

    It’s odd because if I post to LinkedIn or G+ the error does not occur – it is only happening on Facebook. I’m wondering if the above list may match to other plugins people are using and getting the error.

    I guess it’s also time to remove the plugins that are not active – could they still cause a conflict when they are deactivated or even lag? In any case I copied the list to a Google Doc and will begin removing them.

    Be nice to solve this mystery.

    Update – I just deleted all (107) not activated plugins – and still the issue is occurring… investigating further…

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Source Code Has Something Strange’ is closed to new replies.