SoundCloud Shortcode
SoundCloud Shortcode only displays flash player, in spite of settings (3 posts)

  1. sgreve
    Posted 3 years ago #

    Hi everybody,

    I'm trying to use the HTML5 player on my site, but the shortcode only displays the Flash player no matter what I do. I've tried deactivating and reactivating the plugin and deactivating other plugins, but neither have helped.

    I'm doing two things special with my player:

    1. Using the shortcode via another plugin, Custom Field Template. I do this so I can just paste the SoundCloud URL to a custom field, which allows me to build it into the template itself.
    2. Passing it parameters via a template_part because I have a lot of different categories and I wanted to use a custom-colored player for each. However, that doesn't seem to be a part of the problem either.

    Anybody have any idea what's happening? Unfortunately SoundCloud is useless to me without the HTML5 player.


  2. Netz
    Posted 3 years ago #

  3. pekkizz
    Posted 3 years ago #

    Hello, this does not help.

    I have html in soundcloud, then I have this shortcode:

    [soundcloud url="http://api.soundcloud.com/playlists/8304952" params="" width=" 100%" height="450" iframe="true" /]

    <img class="alignnone size-large wp-image-78" alt="Steel-Dildo-Cover" src="http://steeldildo.org/wp-content/uploads/2013/07/Steel-Dildo-Cover-1024x788.jpg" width="625" height="480" />

    in this page:

    Then, I have HTML5 also activated in my SoundCloud Shortcode settings.

    What happens is that Nokia Lumia Phones (support only html5 and not flash) plays the soundcloud page all right, but my Wp site steeldildo.org just gives an error for flash.

    So still - something is making it to use flash in this plugin!
    Please help us if you can??

    Pekka Varis

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • SoundCloud Shortcode
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic


No tags yet.