WordPress.org

Forums

SoundCloud Shortcode
[ Soundcloud Player ] - NO FULL Background image (4 posts)

  1. kaydien
    Member
    Posted 11 months ago #

    Hey there,

    i want to embed the Soundcloud player on my WordPress page.

    - i have installed the "soundcloud shortcode" plugin
    - i have the Explicit Theme

    so far i get working embedded soundcloud player on the post...

    Problem: I create the code from soundcloud to insert on a Post, but i dont get the exact player previewed.

    > I want no full background image

    Here a picture that explains it a bit.

    PICTURE OF THE PROBLEM

    Question:

    - is there a maybe the theme css which overwrites the playersettings?

    best thanks!

    https://wordpress.org/plugins/soundcloud-shortcode/

    [Moderator Note: No bumping, thank you.]

  2. oblivionboy
    Member
    Posted 11 months ago #

    Hey Guys,

    I'm having this exact problem as well. I would just like to have the basic player, not all the album art. Any ideas?

    Thanks in advance! :)

  3. MamaCass
    Member
    Posted 10 months ago #

    the oEmbed for soundcloud on WP defaults to album art view, to get the smaller player just copy and paste this shortcode and add in your track URL

    [soundcloud url="URLOFYOURTRACK" params="color=ff5500&auto_play=false&hide_related=false&show_artwork=true&show_comments=true&show_user=true&show_reposts=false" width="100%" height="166" iframe="true" /]

    (alternatively you can click share > embed > more options on the soundcloud track itself to get the track specific embed code)

    Also; Explicit is an amazing theme, thinking of using it for a future project if I can figure out how to add Soundcloud embeds to the hero slider haha.

  4. jeffmcneill
    Member
    Posted 3 months ago #

    This is the code I used to get the cleanest player (no images at all):

    [soundcloud url="SOUNDCLOUD-URL-CHANGE-THIS" params="auto_play=false&hide_related=true&show_comments=false&show_user=false&show_reposts=false&visual=false&show_artwork=false&show_playcount=false&download=false&sharing=false" width="100%" height="100" iframe="true" /]

Reply

You must log in to post.

About this Plugin

  • SoundCloud Shortcode
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic

Tags

No tags yet.