Support » Installing WordPress » SOS: Can’t select database

  • Resolved collenice


    Hi guys, I am having a problem regarding the installation and the 5-min guide has taken me more than 5 days and still no positive result coming out.

    My whole files seem installed correctly and opening txt file worked ok. When I tried to open the install.php file with “” (I don’t put it under root directory), it shows the following message,

    < Can’t select database

    We were able to connect to the database server (which means your username and password is okay) but not able to select the database.

    * Are you sure it exists?
    * Does the user huangg_com have permission to use the database?
    * On some systems the name of your database is prefixed with your username, so it would be like Could that be the problem? >

    Anyone knows where my problem lies? I REALLY REALLY appreciate it!

Viewing 8 replies - 1 through 8 (of 8 total)
  • It sounds like either you have not created a database or your wp-config file is not set up correctly.

    Look at the detailed install instructions here:, especially steps 2 and 3.

    also do check that your DB is MySql and not SQL or MSQL

    Hi I used service and have called them for 10+ times, the representative said the MYSQL database is set up and everything is set up. The info they provided will be put in the wp-config file right? If it is the case, I am 100% sure the info they sent to me are exactly in the wp-config file.

    Everything is installed correctly but it just didn’t work. I observed there are some others having the same problem. One solved it by adding the database and etc. But my host said the database is installed, meaning the info in the wp-config file would be ok.

    What kind of settings should I do? Thanks in advance.

    Here is another thread, but it seems the problem has not resolved or the answer was not posted out here, sadly.

    This post solves the problem but what’s the meaning of our moderator’s words? QUOTE – Sounds like a problem in you hosting interface. Might talk to your host and tell them you’ve had no luck assigning a user with the proper privileges to the database. — Anyone knows?


    Anyone could help? Cheers…

    “your hosting interface” means (in this context) the user is being assigned to the database but does not have ALL privileges – meaning the host interface isn’t working correctly to assign these privileges – this is rare but does happen.

    for your database name
    I am not saying it isn’t possible but very seldom would this be the name of the database – and that is the error in your op.

    Thanks a lot. I changed to bluehost and the problem solved.



    I had the same problem with “Can’t select database” as well….

    Turns out, I had to figure out how to get into my MySQL control panel….also known as cpanel.

    I contacted my hosting provider (webhostgiant) through online tech support and they gave me the special URL I needed to get into my cpanel.

    Once there, I created a database in the MySQL database. And just like other users on this forum have noted, it created a naming structure by default that was


    Once I did that, everything worked perfectly.

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘SOS: Can’t select database’ is closed to new replies.