Support » Plugin: Google Calendar List View » sorting not working

  • Resolved picapolonica79

    (@picapolonica79)


    Hi!
    Great plugin, but sorting doesn’t work. “General Settings” 1 and 3 are saved to the database, but they don’t work.
    In list-view-google-calendar.php I changed line 297:
    297 ‘orderbysort’ => ”, // ascending or descending.
    297 ‘orderbysort’ => ‘desc’, // ascending or descending.
    So it works.
    I only point it out to you, because I don’t know if it should have been done like this.
    Thanks for the plugin and attention!

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author kimipooh

    (@kimipooh)

    Thank you for using my plugin!

    I released version 6.2 for fixing the issue where sorting from the setting menu was not available. Please update the plugin.

    In addition, you can use the shortcode option.
    ex. [gc_list_view orderbysort=“descending”]
    or [gc_list_view orderbysort=“ascending”]
    The shortcode option is a priority.

    Thread Starter picapolonica79

    (@picapolonica79)

    Hi! Thank you!
    I have updated and now the sorting works.
    Just tell you what happens to me: with the shortcode option [gc_list_view orderbysort = “desc”] it works correctly, instead with [gc_list_view orderbysort = “descending”] the sort becomes ascending.
    Thanks for the attention!

    Plugin Author kimipooh

    (@kimipooh)

    If you set the “orderbysort=desc” on the shortcode option, “orderbysort” is set by “ascending”. Because “orderbysort” is set by “ascending” if you set the setting except “orderbysort=descending”.

    In descending order, the newest date comes at the top.
    If you set the “orderbysort=desc”, the newest date comes at the bottom.
    What is the order of the events on your site?

    Thread Starter picapolonica79

    (@picapolonica79)

    You’re right, sorry, I got confused. With Ascending it works. Thanks for your patience!

Viewing 4 replies - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.