Support » Plugin: Zotpress » Sorting Error Since New Release

  • Resolved aritzhaupt

    (@aritzhaupt)


    Since the new release, the sorting of years and articles is no longer working. Any suggestions?

    The page I need help with: [log in to see the link]

Viewing 15 replies - 1 through 15 (of 15 total)
  • Plugin Author Katie

    (@kseaborn)

    Hmm … can you let me know what shortcodes you’re using and the expected behaviour? On your site, I see dates in descending order.

    [zotpress author=”Ritzhaupt” highlight=”Ritzhaupt, A. D.” sortby=”date” order=”desc” title=”yes” download=”no” urlwrap=”title” target=”new” abstract=”yes” content=”html” cite=”no”]

    Just following up on this. The list is sorting to some extent, but the years are not in order in the sort. It was fine until I updated it.

    Plugin Author Katie

    (@kseaborn)

    I’ve looked at your site as before, and I see dates sorted in descending order, e.g., 2019 -> 2018 -> 2017, etc. Are you seeing something else?

    If you keep scrolling down, you will see that it starts to go out of order. For instance, 2016 and 2015 appear towards the bottom for some reason.

    Plugin Author Katie

    (@kseaborn)

    Ah, I see now. About how many items do you have? Is there anything different with how the dates are formatted for those ones?

    I have 105 items in my Zotero list and they all seem to have dates assigned accordingly. The dates are in a variety of formats, like January 2, 2016 or 2016/07/01. I have no clue why the plug-in would show the results out of order like this based on the dataset I have. I didn’t change anything except update the plug-in to the newest edition.

    Plugin Author Katie

    (@kseaborn)

    Thanks for the info. I’m not sure why there was a change, but I suspect it has to do with the multiple requests (50 item limit). So there would be 3 requests with 105 items. I wonder if this is happening on the third request (last 5 items?), and why. So I will look into it.

    Thanks for your help. I really love this plug-in and want to keep using it!

    Hi Katie,

    I hate to keep asking, but did you make any discoveries associated with this problem I am having. I am now running into an issue where the modification I make with the shortcodes is not even rendering at all. Any suggestions would be greatly appreciated here. I know this is a labor of love. I have some technical experience if you need some help debugging. Just give me some guidance on what to examine in the source.

    Cheers,
    Albert

    Plugin Author Katie

    (@kseaborn)

    Sorry but I don’t have time until November or December to work on Zotpress. I have an inkling of where the error is … it seems that the sorting is not being called after items from the 2nd+ requests are added.

    Plugin Author Katie

    (@kseaborn)

    @aritzhaupt Is this still happening on your end? I went to check today, and I don’t see the problem on your site anymore, and also I can’t replicate it on my end …

    Hi Katie,

    Thanks for the follow-up. I played around with it by removing all attributes and then putting them back in one-by-one. It eventually started sorting again. I have no idea what the problem was or where there is or was a bug. All is well. Thanks again for the follow-up, and again, awesome plug-in.

    Cheers,
    Albert

    Plugin Author Katie

    (@kseaborn)

    One thing I noticed is that you included this attribute, which doesn’t exist: content=”html” I didn’t try it but perhaps it did something unexpected. Glad it’s working now!

    Good catch. I did end up removing it. That may have been the culprit.

    Cheers,
    Albert

Viewing 15 replies - 1 through 15 (of 15 total)
  • You must be logged in to reply to this topic.