Support » Plugin: IP Geo Block » “Sorry, your request cannot be accepted.”

  • Hello,

    Could you please help me with the follwing issue:

    1. Customer advises me that this message appears “IP Geo Block: Once you logout, you will be unable to login again because the number of login attempts reaches the limit. Please execute “Clear cache” on Statistics tab to prevent locking yourself out.”, that sometimes she gets the message “Sorry, your request cannot be accepted.” by clicking certain pages and that after a certain time it would work again.
    2. I delete the IP Geo Block plugin folder on the server.
    3. I login into WordPress using my admin account and reinstall the plugin.
    4. On activation it falls back to the message “Sorry, your request cannot be accepted.”. The dashboard isn’t accessible either. So, I’m unable to access and modify the settings of the plugin.

    I checked this FAQ page and I’m unable to perform Step 1, 3 and 4 because of the mentioned reason. Step 2 shows no Javascript errors.

    In Step 5 I’m not sure what to enter. The URL for the plugin activation is https://www.example.tld/wp-admin/plugins.php?activate=true&plugin_status=all&paged=1&s=. Other URLs would be required too. I doubt that this is the way to resolve the issue. Mind that other customers on the same shared hosting server reported the same thing.

    Final step: Where do I find the mentioned ‘plugin settings section’, is it in the settings of the IP Geo Block plugin? Anyway, I’m trying to list the items of this specific customer:

    PHP and WordPress:
    – PHP 5.6.31
    – WordPress 4.8.1
    – Multisite no

    Theme:
    – Academica Child => other customers with other themes

    Plugins:
    – Add Meta Tags
    – Akismet Anti-Spam
    – Black Studio TinyMCE Widget
    – Broken Link Checker
    – Companion Auto Update
    – Easy HTTPS (SSL) Redirection
    – Footer Text
    – Google XML Sitemaps
    – Image Widget
    – Login Logo
    – MailChimp for WordPress
    – MailChimp for WordPress – Captcha
    – Maintenance
    – Mobile Navigation
    – Page Builder by SiteOrigin
    – Posts in Page
    – Simple IP Ban (not active)
    – SiteOrigin Widgets Bundle (not active)
    – smart User Slug Hider
    – Social Icons Widget by WPZOOM
    – Social Media Widget
    – TinyMCE Advanced
    – Tracking Code
    – Unique Headers
    – WP Limit Login Attempts
    – WP Mailto Links – Manage Email Links
    – WP Mobile Plugin (not active)
    – WP Rollback

    Error log:
    2017-09-12 14:47:48 Warning ***.***.**.*** (32)Broken pipe: mod_fcgid: ap_pass_brigade failed in handle_request_ipc function, referer: https://www.example.tld/wp-admin/plugin-install.php?s=IP+Geo&tab=search&type=term
    2017-09-12 14:57:51 Warning ***.***.**.*** (32)Broken pipe: mod_fcgid: ap_pass_brigade failed in handle_request_ipc function, referer: https://www.example.tld/wp-admin/plugin-install.php?s=ip&tab=search&type=term

    Domo arigato in advance for your help!

Viewing 5 replies - 16 through 20 (of 20 total)
  • Plugin Author tokkonopapa

    (@tokkonopapa)

    Hi @sankari,

    Could you also check the returned status code of the request to captcha.php using browser’s console or developer tool like this?

    Chrome developer tool

    This document is a bit old, but please refer to.

    In your case, I think the HTTP status code might be “403 Forbidden” or “500 Internal Server Error”, but don’t know why 😉

    Hello @tokkonopapa,

    It’s so nice of you to help with this case, thank you so much!

    On the list of plugins it says version 3.0.4.5.

    Here is what I did:

    1. Deactivated Wordfence plugin (which I used as a temporary substitution for WP Limit Login Attempts) and installed+activated WP Limit Login Attempts
    2. Logged out of WordPress => the captcha doesn’t appear
    3. Activated brower console and reloaded the login page => all files including captcha.php are listed with status 200.
    4. Right click on the empty captcha image the check the image address: https://wp.domain.tld/wp-content/plugins/wp-limit-login-attempts//captcha.php. Please notice the two slashes.
    5. Renamed the wp-limit-login-attempts directory
    6. Logged into WordPress
    7. Checked IPGB settings, see below

    System information:
    – Server: Apache
    – PHP: 5.6.31
    – WordPress: 4.8.2
    – Multisite: no
    – File system: direct
    – Zlib: yes
    – ZipArchive: yes
    – BC Math: yes
    – mb_strcut: yes
    – DNS lookup: available [0.5 msec]
    – Glow 1.0.5
    – Akismet Anti-Spam 4.0
    – Anti-spam 4.4
    – Broken Link Checker 1.11.5
    – Companion Auto Update 2.9.6
    – Easy HTTPS (SSL) Redirection 1.7
    – Edit Author Slug 1.5.2
    – Enable Media Replace 3.1.1
    – Footer Text 2.0.2
    – IP Geo Block 3.0.4.5
    – Meta Generator and Version Info Remover 3.3
    – Page Builder by SiteOrigin 2.5.13
    – Posts in Page 1.3.0
    – smart User Slug Hider 1.4
    – Theme Manager 2.0.1
    – TinyMCE Advanced 4.6.3
    – Tracking Code 1.1
    – WP Custom Login Page Logo 1.4.2
    – WP Display Header 4
    – WP Mailto Links – Manage Email Links 2.1.6
    – WP Meta SEO 3.5.2
    – WP Rollback 1.5
    – 2017-09-28 10:30:50 limited GET:/wp-login.php?redirect_to=https%3A%2F%2Fwp.domain.tld%2Fwp-admin%2F&reauth=1
    – 2017-09-27 12:43:04 limited GET:/wp-login.php?redirect_to=https%3A%2F%2Fwp.domain.tldh%2Fwp-admin%2Fpost.php%3Fpost%3D32%26action%3Dedit&reauth=1
    – 2017-09-27 12:43:00 limited GET:/wp-login.php?loggedout=true

    Logs: admin area:
    (empty)

    Validation rule settings:
    – Your IP address / Country: ***.***.**.*** / CH (Cache)
    – Matching rule: Whitelist
    – Whitelist of country code: CH,LI
    – Bad signatures in query: ../,/wp-config.php,/passwd
    – Prevent malicious file uploading: Disable
    – Response code (RFC 2616): 403 Forbidden
    – Response message: Sorry, your request cannot be accepted.
    – Max number of failed login attempts per IP address: Disable
    – Validation timing: “init” action hook

    Back-end target settings:
    – Comment post: Block by country
    – XML-RPC: Block by country
    – Login form: Block by country
    – Admin area: Block by country
    – Admin ajax/post: Block by country
    – Plugins area: Force to load WP core, Block by country; Exceptions: WP Mailto Links – Manage Email Links
    – Themes area: Force to load WP core, Block by country

    I checked a WP website on another server where both IPGB and WP Limit Login Attempts are active and the captcha doesn’t appear there either.

    For your info: After deactivating IPGB and logging out of WP the captcha image appears as intended. The URL of the image is the same (containing two slahes), so it seems to be correct.

    Plugin Author tokkonopapa

    (@tokkonopapa)

    Dear @sankari,

    You’re the Savior of mine!

    – 2017-09-28 10:30:50 limited GET:/wp-login.php?redirect_to=https%3A%2F%2Fwp.domain.tld%2Fwp-admin%2F&reauth=1

    – Max number of failed login attempts per IP address: Disable

    I found a bug which set the number of login attempts as “limited” immediately when login fails.

    I’m now dedicating to solve another issue around validating login attempts. So please wait until I finish my work.

    I’d like to really appreciate what you’ve done!!

    @tokkonopapa: We can call it joyful team work 🙂 And the gratitude is mutual. Good luck for fixing the bug!

Viewing 5 replies - 16 through 20 (of 20 total)
  • The topic ‘“Sorry, your request cannot be accepted.”’ is closed to new replies.