Support » Installing WordPress » Sorry, you need to enable sending referrers, for this feature to work.

  • I have done the following:

    Internet explorer: put the site URL in both Security and Privacy tabs

    Zone Alarm: changed my site and WordPress sites to allow 3rd party cookies

    Checked in my database that wp-options had the correct URL

    I know the instructions say to change the name of .htaccess but my provider had to modify it to support Firefox to show CSS properly and I don’t want to touch it.

    What else should I try?

    TIA

    Sue

Viewing 8 replies - 31 through 38 (of 38 total)
  • I had most of the problems listed above and I finally found a combination of things from the codex that got it to work. Then I added a mod_rewrite to my .htaccess to 301 redirect non www to http://www.domain.com (with my base URI set to the non www version). I couldn’t do much of anything anymore + all the admin pages lost their stylesheet.

    I tried to change a lot of the security privacy settings to no avail. I then checked the base URI and switched it to the www version and all is well. I then turned off most of the “trusted zone” part in IE because it kept prompting me ever time I changed pages. All is OK now.

    Is this whole problem related to the base URI in wp-options? Very strange.

    Thanks for the info though, it prompted me to review the base URI.

    martin

    I finally got it to work. I had set both
    WordPress address (URI): http://example.com
    Blog address (URI): http://example.com

    And then went back and added an .htaccess file that redirected all urls to add http://www., thus creating http://www.example.com as my blog address.

    After I did this, it messed everything up for a while, and I kept getting this error. Finally, somebody said something in a post that triggered my memory, and I went in, changed the above settings in Options to reflect the addition of “www.” and now it all works again.

    Very Happy.

    Just a note, this had nothing to do with Norton, ZoneAlarm, my browser or my operating system, as I had the same problem on Macs, Pcs, Opera, Firefox, IE 6, and Safari. (referenced to help other people with a similar problem.)

    Griffith’s example worked for me. I was trying to use an add-on domain as the WordPress address and Blog address in Options. I changed the URIs to http://MyBlogsIPaddress/add-on_domain_name and it worked properly. No more enable sending referrers messages, and the style sheets started working. Note that the default settings for these two Options fields were set by my hosting provider’s installation script for WP.

    I´m having the exact same problem, but only I cant change the blog.domain.com back to http://www.domain.com/blog because I cant change anything in my admin, because he keeps saying that I should enable sending referrers.
    I searched the DB, but I couldnt find where to change, can somebody help me?

    I had a similar problem to what a few of you had, but it occured when I decided to move everything from the blog folder to the root directory (from http://www.site.com/folder to http://www.site.com). I put a copy of the blog in the root directory first, just in case something went wrong. Because I changed blog locations in the admin panel before making a copy of the blog in the new location, things were tangled after the copying (old links at new location, new links at old location) and I could not make changes without getting thrown to the other admin panel’s login screen or getting the “enable sending referrers” message.

    To solve this problem, I had to make a backup of my SQL database and edit it to fit in the blog’s new location and then restore it there. Then, I went through phpMyAdmin to change the location of the blog. It did not occur to me until later that I had to change the blog address on the admin panel at both locations to the old one. After saving it, I was automatically logged out, and when I logged back in I was presented with a list of the same options I saw at phpMyAdmin, which contained the changes I saved there earlier. I clicked the Update button to confirm everything, and finally the site was working at its new location.

    I’m only getting the message that I need to enable referrers when I try to change categories on my links. I was, before today, getting it all the time… but my ISP gave me a quick fix, which was to go into my hosts file under Windows/System32/Drivers/Etc and add my blog address into that. Sure enough, the situation stopped being the nightmare it had been… until today, when I imported my blogroll…

    Any ideas? I am completely new to WordPress, php, et al. And thank you in advance for any help you can provide.

    I fixed this via a hint from one of the third posts.

    wp-admin
    options
    Membership: Users must be registered and logged in to comment

    Turn this OFF to enable post Save-continue-edit or Save-publish

    Obviously not idea, but it is a workaround.

    Hi,

    I just found this thread because I had the same problem. I figured out how to fix it if you are using ZoneAlarm without messing with anything in detail.

    1)Open ZoneAlarm Security Suite.
    2)Goto the “Privacy” section.
    3)From there, goto the “Site List” subsection.
    4)Add your site to the list if it is not already there.
    5)Under the “Private Header” checkbox, check it green.
    6)Now it will work because ZA will no longer block private headers from that site.

    Easy day right? This is using the full zone alarm though, I’m not sure if it is the same with the free version. Good Luck.

    Jeremy

Viewing 8 replies - 31 through 38 (of 38 total)
  • The topic ‘Sorry, you need to enable sending referrers, for this feature to work.’ is closed to new replies.