WordPress.org

Forums

Sorry, you need to enable sending referrers, for this feature to work. (39 posts)

  1. sjmagain
    Member
    Posted 10 years ago #

    I have done the following:

    Internet explorer: put the site URL in both Security and Privacy tabs

    Zone Alarm: changed my site and WordPress sites to allow 3rd party cookies

    Checked in my database that wp-options had the correct URL

    I know the instructions say to change the name of .htaccess but my provider had to modify it to support Firefox to show CSS properly and I don't want to touch it.

    What else should I try?

    TIA

    Sue

  2. sjmagain
    Member
    Posted 10 years ago #

    Turning off Zone Alarm makes the error message disappear. But I'm confused. It made my site a trusted site so what am I missing?

    TIA

    Sue

  3. sjmagain
    Member
    Posted 10 years ago #

    Can I assume that there is no solution and WordPress is not compatible with Zone Alarm?

  4. RustIndy
    Member
    Posted 10 years ago #

    Check the codex at http://codex.wordpress.org/Enable_Sending_Referrers for information. The "sending referrers" problem is pretty common, and can happen for about a thousand different reasons. All of the common causes and solutions are in the codex link above :) If you check that, then try installing a different browser (like Firefox or Opera) and see if that makes a difference. If it's still broken, then hit this thread again and let us know.

  5. sjmagain
    Member
    Posted 10 years ago #

    Thanks, RustIndy. I have been through the codex and followed it carefully. The problem appears to be with Zone Alarm. Interestingly, it's causing another problem with my website so I've contacted Zone Labs for assistance. If not, I'll be back.

    Thanks again.

    Sue

  6. kuroneko
    Member
    Posted 10 years ago #

    uhm...i tried the thing instructed on that link for codecs, sady, it still won't let me post links... i'm not the owner of my blog, well, my friend just hosts me...i was wondering if anyone can help me on this. i am now using my laptop to access my blog, but the old pc (w/c broke down) didn't have this problem. i was using firefox when i tried the about:config thing and i did delete my cookies. hope someone can help me. thanks~

  7. tradefor
    Member
    Posted 10 years ago #

    Hello
    1. I am browsing with IE6, on XP. with Norton Personal Firewall 2004 installed.
    2. WP 1.5 was installed by my host co., and configured properly - I believe.
    3. I can log-in as Admin
    4. I cannot do a simple thing like change the Default theme to Classic (just to see what it looked like), which leads me to believe other things won't function either.
    5. I have reviewed your codex http://codex.wordpress.org/Enable_Sending_Referrers
    and permitted my blog's URL for trusted site and privacy in IE6
    6. I stepped my way through your instx, on Nortonal Firewall. I even tried disabling Norton Firewall completely and that made no difference - I still got the error message.
    7. The WordPress address and the Blog page are both "http://mydomain.com/blog"
    7. I am not very techy, but can follow simple instructions if laid out fully.

    I have only a limited time to get this fixed before I must uninstall it and try something else.

    Anybody got a short-list of other usual suspects that cause this error message?

  8. Mark (podz)
    Support Maven
    Posted 10 years ago #

    Do you have anything at all that could block cookies ?
    Any privacy program / cookie manager ?

  9. Jinsan
    Member
    Posted 10 years ago #

    I've found this problem most common with software firewalls and WP - less so, if at all with others. It's not so much a flaw, but a secuirty feature, which the firewalls seem to have trouble in the way WP requires header info. Even adding it to the trusted list or accepting only cookies from make little difference.

    THe only solution that I have used is to turn off the privacy features, do what I need to in WP then turn them back on. For browsing it's not such a big issue, but for editing and logging in it's a headache. Again I say it's not WP, but the way the firewalls seems set to accept certain ways in which it assumes something will work.

    At the same time, it might be easier to get WP working with the firewalls, than getting the firewalls to work with WP.

  10. visibleh20
    Member
    Posted 10 years ago #

    Sorry, you need to enable sending referrers, for this feature to work.

    ======

    I checked out the various methods of advice to end this question... I use Firefox... the refferer under headercontent was at 2 but I tried 1 as well... all to no avail... I still revieve the error message....

    I went over to IE and used the Codex instructions there as well and still I recieve the enable sending referrers error message... Do any of you here have any suggestions... I obviously cannot continue until I figure this out.

    Thank you for any assistance.

  11. Jinsan
    Member
    Posted 10 years ago #

    I don't think it is FF that' sthe problem, do you have any software firewall installed?

  12. visibleh20
    Member
    Posted 10 years ago #

    Yes I do have firewall...

  13. Jinsan
    Member
    Posted 10 years ago #

    Software firewall right? ZA? Kerio? Norton's? Have you read any of hte above?

    Dsiable ALL privacy features, that means cookie blockers, features which remove your header info and so on and so forth. Disbale them all and it shoudl work.

  14. visibleh20
    Member
    Posted 10 years ago #

    oh... then no I don't have firewall then... sorry! I did erase the cookies recently... but that didn't do anything either.

  15. Jinsan
    Member
    Posted 10 years ago #

    ok now you've confused me.

  16. Tek
    Member
    Posted 10 years ago #

    Norton Firewall does this to me. I just turn it off when updating.

  17. tradefor
    Member
    Posted 10 years ago #

    Tek: Thank you.

    I have also found that I also have to turn off Norton Firewall *completely* (I must have reatined something or other when I tried this before) , and not just step through the Norton instuctions on the codex.

    I am completely new at WordPress and not technically inclined, so the large amount of time that I will have to spend totally unprotected makes me deeply unhappy.

  18. visibleh20
    Member
    Posted 10 years ago #

    Oh... yes thanks for that information... I forgot that I still had Norton... I thought it had lapsed....

  19. colombo
    Member
    Posted 10 years ago #

    This keeps coming up for me as well no matter whether I'm using a computer with Norton or Zonelabs. I don't think it has anything to do with the firewall. But, what do I know. Anyone come up with a definite fix? Thanks.

    Al Colombo, http://www.e-commkiosk.com

  20. colombo
    Member
    Posted 10 years ago #

    Sorry, just read the last few messages. I had to turn my Norton firewall off and it worked. Thanks!

  21. trepryor
    Member
    Posted 10 years ago #

    For me, I can post fine but adding a Link is the problem. It's not Firefox or IE and I don't have a firewall installed, only AntiVirus. This didn't happen before I upgraded from 1.2 to 1.5 so it's something to do with WordPress. None of the items in: http://codex.wordpress.org/Enable_Sending_Referrers did the trick.

    Deleting Cookies didn't work.

    Where is the .htaccess file located?

    Re: "verify that the siteurl setting in the wp_options table of your database is set to the root folder of your WordPress installation"

    How can this be accomplished?

    I really love WP but problems like these are so frustrating. Please help if you can.

  22. Sproke
    Member
    Posted 10 years ago #

    I'm having a similar problem to trepryor.
    I could do everything fine in 1.2.1.1 then have just upgraded to 1.5.1.2 and I can't activate my plugins because I get the refferrer message. I've been through that guide in codex.wordpress.org, but nothing there worked either.

    I am about to try shutting of my Nortons A & Firewall, but I really don't want to be doing that all the time, because I hate being attackted - and I get it a lot too.

    Anyone found any other solutions yet?

  23. andrew001
    Member
    Posted 10 years ago #

    Hello trepryor, sproke, all,

    first of all, thank you for the last way to do changes in WP - shutting down Norton Security - no irony!

    I tried everything in the "doc" and checked the posts here too. Horrible.

    Interesting to me, and maybe new is, that i can admin my WP latest version 1.5.1.2 (not update, but fresh install in a subdirectory) with respect to adding new stuff - such as pages, posts etc. so far.

    The problem occurs only (referrer), when I want to delete a single page.

  24. jaxadora
    Member
    Posted 9 years ago #

    I'm really annoyed. I've followed all the instructions and yet as the admin of the blog I still get the message regarding "referrer". I don't know what else to do. In the older version I had no problems what so ever. I've tried to change the parameters of both my desktop and laptop and still get the same issues. Do I need to re-install the program? I've been working on this for hours and I'm about ready to just go back to eblogger without the hassles.

    Can someone help me? I have Norton, XP, Spysweeper... I use IE and sometimes AOL browsers.

    Thanks, Jax

  25. Try temporarily disabling Norton. Do you still see the error?

  26. jaxadora
    Member
    Posted 9 years ago #

    I disabled my anti-virus and it worked, but that's going to leave my system vulnerable. What can I do to protect my computer while I make these changes every time?

    Is there a way that I won't need to have my anti-virus off?

  27. Do you have the latest version of Norton A/V with all of the recent updates? My PC has Norton AntiVirus 2005 and I have no problems working with my blog on it.

  28. Jinsan
    Member
    Posted 9 years ago #

    Norton is a whore - I'd use something else to be honest. I was a Norton user, then saw how Symantec Corp worked in the offices and compared to Norton, Norton was the bastard child no one wanted. It's horrible.

    If your A/V is causing header referrers not to go through, you need think twice about using it.

    You do NOT have to turn off your Firewall completely. That's bad practice, and to do that for ANY software, even WP is bad advice. You could be th eunlucky sucker who gets hit by a 2 year old script kiddy.

    More often than not, these firewalls now have built in privacy features which are absolutely rubbish and do nothing to protect the computer as such. you need to turn off the privacy features, not your firewall's or edit your browsers to allow referrers if they're disabled. Do NOT turn off your firewall.

    A/V is not such a big issue, as long as you have firewall you should be controlling what goes in and out of your system and if you're working on WP then there shouldn't be any problem turning it off. Still, it's probably a setting in the A/V software causing the problem and you have to add exclusion and exceptions.

  29. ((slightly off topic))

    I'll be ditching Norton for ClamWin. It's free, open-source, and better.

Topic Closed

This topic has been closed to new replies.

About this Topic