Support » Plugin: AMP » Sorry, you have Javascript Disabled

  • Resolved susanacu

    (@susanacu)


    A message appears only on android mobile phones using the Firefox browser. Android V 5.1.1, firefox V 86.1.1. The message is as follows:

    Sorry, you have Javascript Disabled! To see this page as it is meant to appear, please enable your Javascript!

    (Note: all posts have the same issue.) I am using WordPress V 5.8.

    The plugins with the issue are “WP Content Copy Protection (Lite) Ver. 2.0.4” or AMP Version 2.1.2. When I disable one or the other plugin, the issue resolves itself. This started right after I updated WordPress to V 5.8. Note; Firefox cannot disable Javascript. It seems OK with both plugins when viewed with Chrome and MS Edge.

    The page I need help with: [log in to see the link]

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Support James Osborne

    (@jamesosborne)

    Thanks for reaching out. While it looks like you have AMP deactivated at present I did check some AMP URLs with Firefox on Android using a test site with the WP Copy Content Protection (lite) plugin and I was unable to recreate the same experience with default configurations (on both Firefox and the plugin).

    Note that the plugin you’re referring to makes use of custom JavaScript so it’s not expected to work in AMP URLs anyway. You can however use the plugins suppression tool to restrict it from running on AMP URLs before checking once more does the same issue occur on Firefox for android.

    Let me know anyway if you do wish to activate AMP once more, while suppressing the WP Copy Content Protection plugin on AMP URLs.

    Plugin Author Weston Ruter

    (@westonruter)

    Note also that the AMP plugin will automatically unwrap noscript tags to be become the AMP version by default. Since AMP doesn’t allow JavaScript loaded in the traditional way in order to help guarantee performance and security, the AMP plugin scripts it out. When markup has been coded to account for visitors who have JS turned off, to provide a fallback experience, then this is what the AMP plugin tries to provide by unwrapping noscript elements. I suspect the WP Content Copy Protection plugin is adding such a noscript to the page.

    Plugin Support Bethany Chobanian Lang

    (@shetheliving)

    @susanacu As we haven’t received a response, I’ll mark this as resolved. Feel free to open a new support topic if you continue to encounter issues, or reopen this topic and we’d be happy to assist. Thank you!

Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.