Support » Plugin: Error Log Monitor » Sorry, you are not allowed to change these settings.

  • Resolved jimmb

    (@jimmb)


    Hello – I’ve installed and activated this plug-in, and then followed the instructions via the plug-in’s help text to add the necessary “php-errors.log” file and point to its location in the “wp-config.php” file…

    And now on the Dashboard, the ‘PHP Error Log’ section shows “The log file is empty.” I assume this means everything is set up correctly and no errors have been logged yet …

    However, when I click ‘Configure’, I get the message:
    Sorry, you are not allowed to change these settings.
    (plus a vaguely confusing ‘Submit’ button underneath)

    Since this seems like something may be wrong, I wanted to double check why I’m not able to reach the ‘Configure’ form and what should be done — if anything — to fix it.

    Thanks,
    Jim

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Author Janis Elsts

    (@whiteshadow)

    And now on the Dashboard, the ‘PHP Error Log’ section shows “The log file is empty.” I assume this means everything is set up correctly and no errors have been logged yet …

    That’s correct. The “log file is empty” message means that the log file exists and the plugin can access it, but there are no error messages in the file (probably because the file has just been created).

    However, when I click ‘Configure’, I get the message:
    Sorry, you are not allowed to change these settings.
    (plus a vaguely confusing ‘Submit’ button underneath)

    That could be a problem with user permissions. You need the update_core capability to change the configuration. Usually, this means that you have to be logged in as either an Administrator or a Super Admin (if it’s a Multisite network).

    The “Submit” button showing up is an oversight. It probably shouldn’t be visible in this situation. I’ll see if I can hide it in the next release.

    Thanks for the Reply, Janis. Strangely, I have tried this when logged in with 2 different Admin accounts, and in both cases it’s still showing that message. (Note: one of these accounts is the “Admin” account that is launched when clicking ‘WP Admin’ inside the GoDaddy portal).

    I guess I’ll need to figure out why these admin accounts don’t have the update_core capability …. But I’ll mark this issue as resolved, since it appears this is a separate problem.

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Sorry, you are not allowed to change these settings.’ is closed to new replies.