Support » Plugin: Really Simple SSL » Sorry, you are not allowed to access this page: upon installing Real Simple SSL

  • Resolved pgattu

    (@pgattu)


    I am using Cloudflare’s SSL certificate with my site.

    * As soon as I installed Real Simple SLL plugin, my site was down completely with ERR_TOO_MANY_REDIRECTS error. I worked around this issue by adding $_SERVER[“HTTPS”] = “On”; to the wp-config.php file.

    * Now I am able to access my public site at https://tavya.com, but I am unable to access https://tavya.com/wp-admin/. I get the login page, but after login, I get this error: “Sorry, you are not allowed to access this page”.

    Please help in resolving this.

    Things I tried:
    * Disabled Real Simple SSL by remaining the Real Simple SSL plugin folder (I added a suffix of “-disabled”).

Viewing 15 replies - 1 through 15 (of 16 total)
  • Plugin Contributor Mark

    (@markwolters)

    Hi,

    this could be caused by an issue with cookies. Could you try if logging in using a private browsing windows resolves the issue? If so, you can clear cookies from your browser to fix the issue.

    Thread Starter pgattu

    (@pgattu)

    @markwolters I already tried clearing cookies and trying from a different computer, but no luck.

    Plugin Contributor Mark

    (@markwolters)

    Hi @pgattu,

    if logging in doesn’t work after clearing cookies it could be there’s an issue with your user account. However, it’s unlikely that this is caused by Really Simple SSL as the plugin does not alter user permissions. You could try disabling plugins by renaming them in the /wp-content/plugins/ folder to see if a plugin is causing the issue. For example there could be an issue with a security plugin. You could also try if updating the password directly in the database resolves the issue. See https://www.bookwebmaster.com/wp/get-wordpress-username-and-password-from-the-database/ for instructions on how to do that.

    Thread Starter pgattu

    (@pgattu)

    There are no other security plugins installed. The issue started instantly after installing and activating Really Simple SSL. So I am confident that the issue is caused by Really Simple SSL. Disabling the plug-in did not help either – looks like the damage was already done. At the time of activating Really Simple SSL, it showed a message that configuration changes will be performed by the plugin. I am guessing these “changes” broke my site. I wish there is a way to undo the “changes”.

    I tried changing the password from the database but it did not help.

    Plugin Author Rogier Lankhorst

    (@rogierlankhorst)

    You can completely revert all changes by following these steps:

    https://really-simple-ssl.com/knowledge-base/uninstall-websitebackend-not-accessible/

    Thread Starter pgattu

    (@pgattu)

    @rogierlankhorst Your suggestion worked. Thank you!

    Hi, I am dealing with this same problem.
    The moment I installed Really Simple Ssl and activated it. It when from online to not found.

    Please help. I have 5years of data on this site. Tried almost everything.

    Any help in this is really appreciated @rogierlankhorst

    Uday

    website is

    http://www.simplynotes.in
    Unable to access wp-login or any page
    Just showing 404 not found.

    • This reply was modified 3 months, 3 weeks ago by udaykpr.
    • This reply was modified 3 months, 3 weeks ago by udaykpr.
    Plugin Author Rogier Lankhorst

    (@rogierlankhorst)

    @udaykpr it looks like your SSL certificate is not valid: https://www.ssllabs.com/ssltest/analyze.html?d=www.simplynotes.in&latest

    You can either install one with Really Simple SSL, or get one from your hosting provider.

    While the SSL is not installed, you can deactivate Really Simple SSL to get back to http.

    https://really-simple-ssl.com/knowledge-base/uninstall-websitebackend-not-accessible/

    Hi @rogierlankhorst

    Yes, my website did’nt have ssl. I was silly to add really simple ssl even though we dont have ssl.

    I tried everything listed on the link to revert my website back. But still I am unable to do that.

    Pleases help me with this. I can share cpanel details so that you can check with the same.

    My wife the one who was handling this and she is crying since last 3 days and we are loosing visitors every day.

    Please help

    Uday

    cont.
    Currently, I linked my website to old slow data which not of much use.

    I am willing to pay, if required to fix this.

    Uday

    Plugin Author Rogier Lankhorst

    (@rogierlankhorst)

    @udaykpr please don’t offer to share access details, that is not allowed on the forums.

    If the built in deactivation doesn’t work, you can also use the manual deactivation:

    https://really-simple-ssl.com/knowledge-base/when-the-built-in-deactivation-does-not-work-manual-uninstalling/

    Just putting back the site url and home url and renaming the plugin folder will resolve issue in most cases. Don’t forget to clear your browser cache.

    I am sorry if I broke forum rules. I am very anxious to bring my wife site backonlien.

    Yes, I did that (manual removal). Checked twice. But its not working. Cant say why.

    Please suggest, what can be done.

    Uday

    Plugin Contributor Mark

    (@markwolters)

    Hi @udaykpr,

    there’s still a redirect to https:// active. This has to be removed first. If you have deactivated Really Simple SSL using the force-deactivate script, but the site still redirects to https://, there must be a different redirect active. This could come from either your .htaccess file or for example an https setting in your hosting control panel. If you could post the contents of your .htaccess file in this thread we can check this for you.

    Hi,

    when I use the force-deactivate.php, it was showing not found.
    So I tried using manual method, it didn’t work.

    here is .htaccess

    text/x-generic .htaccess ( ASCII English text )
    # BEGIN WordPress
    # The directives (lines) between "BEGIN WordPress" and "END WordPress" are
    # dynamically generated, and should only be modified via WordPress filters.
    # Any changes to the directives between these markers will be overwritten.
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    # END WordPress
    Thread Starter pgattu

    (@pgattu)

    @udaykpr I can try to help you. I just resolved this issue for my own website. I don’t feel comfortable posting my contact info on an internet forum. If you feel comfortable posting your email or phone, I can contact you. You can Edit your post to remove your contact info after we make contact.

    • This reply was modified 3 months, 3 weeks ago by pgattu.
    • This reply was modified 3 months, 3 weeks ago by pgattu.
Viewing 15 replies - 1 through 15 (of 16 total)
  • You must be logged in to reply to this topic.