Support » Plugin: Awesome Support - WordPress HelpDesk & Support Plugin » Sorry, you are not allowed to access this page.

  • Resolved Roberto Fietta

    (@webagile)


    Hi, trying to enter the settings: “Sorry, you are not allowed to access this page.”

    Awesome Version 5.8.0
    WordPress 4.9.8

    Regards,
    Roberto

    The page I need help with: [log in to see the link]

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author melliesou

    (@melliesou)

    Hi Roberto,

    My first impression is that the user/login you are currently using does not have the the role or permissions set in order to “administer” your tickets plug in. You must be an “AS Admin” (Awesome Support Admin) or full Admin in order to edit the settings. If you are still getting the error, ensure that your role settings explicitly allow you the option to “administer_awesome_support” from within the “Role Settings” from the “Users”->”User Role Editor” section.

    Hope the above helps you. Please let us know if you still cannot access that page after checking those settings.

    User has Administrator role in WP, and administer_awesome_support capability.
    Please note that everything was working fine since some days ago, and no changes in the user details or capabilities.

    I tried to logout and reconnect: AWS Settings disappeared from the menu.

    Regards,
    Roberto

    Plugin Author melliesou

    (@melliesou)

    Hi Roberto,

    Can you confirm which version of PHP is running on your system? Since the plug-in is not showing in your menu, you may benefit from running in debug mode https://codex.wordpress.org/Debugging_in_WordPress and seeing if there are any conflict errors.

    Beyond that, if you try deactivating and then reactivating the plug-in. And then also try deactivating other recently added plug-ins to verify there is no conflict. Based on that, if those don’t help, it may make sense to try uninstalling and re-installing the plug in. It’s possible that some files may have been lost in a backup/restore of your site?

    I hope those above steps will help to sort out the root issue here. I’ll watch this thread for any updates from you.

    PHP version is 5.6.39, the same as our staging environment, where Awesome settings works. The only difference in the WordPress version: production has WP 4.9.8, staging has the newer 5.0.1.
    Regards,
    Roberto

    Plugin Author melliesou

    (@melliesou)

    Hi @webagile,

    Can you confirm if you tried the steps from this post after checking the PHP version? https://wordpress.org/support/topic/sorry-you-are-not-allowed-to-access-this-page-76/#post-11002547

    If you did the above steps and it’s still not working, you can try to upgrade WordPress to 5.0.1; however, the version here should not be the main factor. It might be necessary to debug more.

    Hope the above is helpful. And if you have more details about settings differences between the two installations, we can take a closer look.

    Plugin Author melliesou

    (@melliesou)

    Hi @webagile,

    I’ll mark this ticket as resolved based on the common troubleshooting options listed as well as analysis unique to your set up. If the above doesn’t meet what you need, please let us know and we’ll assist with investigating.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Sorry, you are not allowed to access this page.’ is closed to new replies.