Support » Plugin: Redis Object Cache » Sorry, you are not allowed to access this page.

  • Fresh install of WP 4.9.6 running Redis 3.0.6 and PHP 7.2.7.

    All looks good except when I log out and log back in.

    “Sorry, you are not allowed to access this page.”

    Issuing a Redis Flush resolves the issue.

    I would love to use Redis over Pagespeed, but this isn’t a good sign.

    What is root cause, and how can it be resolved?

    Thanks!

    ~ A.I

Viewing 7 replies - 1 through 7 (of 7 total)
  • Daniel Kanchev

    (@danielkanchev)

    SiteGround Representative

    @amistacx this issue is rather strange. Are you able to recreate the issue every single time you enable the Redis plugin? My advice is to dump all keys in the Redis database and carefully check them one at a time. You can use the “KEYS *” command with redis-cli to see the keys.

    Once you see all the keys you can find the one which is problematic and try deleting just this one key to see if the issue is resolved. Once the problematic key is identified it will be much easier to resolve and debug the issue.

    For more details about the Redis command check this link:

    https://redis.io/commands/keys

    If you cannot recreate the issue every single time when the plugin is enabled then I suppose something strange happened when you used the plugin for the first time and that is why the error was displayed on your end. I personally use this plugin on many sites – some of them are huge and I don’t have issues with it.

    I’ve been having this same issue. I’ve narrowed it down to the “user_meta” key. I haven’t quite figured out how to resolve the issue though.

    Just happened to me today for one site. All admins were locked out with this error. Issuing this command in WP CLI solved our problem:

    wp role reset --all

    I tried wp role reset --all and it did nothing. It said no roles needed to be reset, and the issue still persists.

    @sincspecv did you flush redis? sudo redis-cli flushall

    It solved the issue temporarily but came back. We have not had the opportunity to debug the issue on our side for exact cause as per Daniel’s suggestion.

    @amistacx flushing the cache does fix the issue until I log out and then try to log in again. Deleting the user_meta key does the same thing. I’ve added user_meta to the ignored groups array, but that doesn’t seem to do anything at all.

    ntripl

    (@ntripl)

    Same issue here

Viewing 7 replies - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.