Support » Plugin: Transient Cleaner » Sorry, You are not allowed to access this page.

  • Trying to use ver 1.5.4 of Transient Cleaner on my WP 4.9 dev site, but I keep getting this error message. I’ve tried logging in as the admin account as well as my id which is also an administrator but it made no difference. I read through the old but now closed thread on this same issue but saw no resolution.

    Do you have any new ideas?

    Also, I’m using the Settings option right next to Deactivate. In the docs you refer to Administrtation -> Tools -> Transients, but I don’t see that anywhere, am I missing something is are the docs in need of an update?

    Thanks for your help.

    The page I need help with: [log in to see the link]

Viewing 15 replies - 1 through 15 (of 22 total)
  • Plugin Author David Artiss

    (@dartiss)

    Hi John,

    Interesting. Can you not see the menu option that I’ve highlighted here… https://cloudup.com/ctz1lVnJN5k ?

    I’m guessing not. On my own installations, both the menu displays and the ‘Settings’ link you’re using works too. It looks as if the menu hasn’t installed itself for some reason. It’s not, as I thought might have been the case before, a clash of menu names, where another plugin is using the same ‘hook’ – I’ve named mine ‘tc-options’, which is pretty unique, and even if this wasn’t the case I’d expect you to be directed to another plugins’ page in this situation and not get an error.

    Did you get any errors when you activated the plugin?

    Is there anything unusual about your installation? Are you running it locally, on a multisite, etc?

    No, I do not see that option under Tools, Just the Settings under the activated plugin itself where I get the error message.

    I did not get any errors when I activated the plugin. I am running this plugin in my staging site on SiteGround where I test things. It’s an auto-setup by SiteGround and I don’t know all of the things they do which could conceivably screw up the plugin, but I can tell you that n this install I have 42 active plugins and 102 inactive, which I turn on and off as I try things out. Nothing else has been a problem so far, that I know of. I do keep WP and all plugins in this staging area current.

    Plugin Author David Artiss

    (@dartiss)

    Hmm. I can’t think of any obvious reason why this wouldn’t work but I wonder if it’s to do with it being a staging site – I may be making too much of an assumption about where to expect to hook the menu too.

    Leave this with me John and I’ll see if I can find anything obvious.

    Plugin Author David Artiss

    (@dartiss)

    I’ve just thought of another question – when you click on the ‘Settings’ link against the plugin name, what URL does it try to take you to? Can you cut/paste it here exactly as it appears?

    Plugin Author David Artiss

    (@dartiss)

    Hmm, nothing odd there. Can you click on the Tools menu option and tell me what URL appears then?

    I also assume your user profile is set as admin?

    Hi David,

    I too have been having this issue now on/off for over a year. I was about to write to you about this and saw this thread.

    I’m not 100% sure of all the causes, but I do have evidence of one possible cause…

    I’m running multiple environments for our site, a production site, development, local, etc. I just discovered that this problem was occurring only on the production site, and I think I may know the cause.

    We use the following constant in our wp-config.php file on the production site to disable the ability for any updates or changes directly in that environment:

    define(‘DISALLOW_FILE_MODS’, true);

    This basically prevents things like WP updates, plugin updates, editing files, from directly occurring on the production site. It’s a great precaution, and it serves us well.

    I think this may be causing this issue with your plugin. I have noted that when attempting to access a page not allowed under this constant that it displays this message. The fact your plugin works in my local environment but not in our production environment tells me this is the likely cause.

    Try putting this constant in your config file and see if it has the same result. If it does, you know what to fix.

    As to whether or not this is the only cause of this problem, I do not know. But I’d love to see this solved as I want to get your plugin working again!

    ~ Michael

    Plugin Author David Artiss

    (@dartiss)

    Thanks for the suggestion Michael – I tried that but still wasn’t able to recreate it. I didn’t think that would be it as my plugin is not making any file modifications, which is what that line prevents.

    It’s an interesting one for sure but without a way to recreate this I’m a little stumped. Are you able to do the same thing as I asked John? Click on the ‘Tools’ menu item and then tell me what URL appears in your browser bar?

    Plugin Author David Artiss

    (@dartiss)

    A-ha, may be onto something (thank goodness for Google)…

    Do you have access to the theme/plugin editors under Appearance > Editor? (this is a question to either of you)

    Plugin Author David Artiss

    (@dartiss)

    No, ignore that. Thanks to a fellow developer, I’ve got to the bottom of this. There are two circumstances under which the menu won’t appear…

    1. You have define( 'TC_LITE', true ); set-up in your functions.php. I’m guessing this isn’t the case here as you’d have had to have done this on purpose.
    2. You site is using object caching – transients are stored in memory and not the database, and hence this plugin can’t do much. However, you should have a warning box at the top of your admin screen to tell you this. Do you have anything displayed?

    Yes, that’s it. Here’s the message:

    “An external object cache is in use so Transient Cleaner is not required. Please disable the plugin!”

    I’m using the plugin Dobby on my staging site to control those admin messages and didn’t see this one until this morning. I came here to advise you, but you’d already figured it out.

    @illuminice I do not have that line in my wp-config, FYI.

    Hi David,

    Thanks for the quick replies. It looks like the source of my problem is different than John’s.

    I’m glad you’re able to confirm that DISALLOW_FILE_MODS is not the cause. That’s helpful. I also checked for the TC_LITE in my functions.php (both of them), and it’s not there.

    Regarding using object caching, I’m not sure if this is the case. I don’t think so, but will investigate further. There is definitely no warning message in the admin about this.

    When I activate the plugin, it simply doesn’t display anywhere in the admin. If I click the settings link from the plugins screen I get the following error:

    Sorry, you are not allowed to access this page.

    If I click on the Tools menu I get this URL:
    https://domainname.com/wp-admin/tools.php

    This is the URL I see when clicking on the settings link from the plugin screen:
    https://domainname.com/wp-admin/tools.php?page=tc-options

    At that point I just see the access error.

    One other possible cause here is the environment. As I mentioned earlier the plugin functions in my local environment. Our production site (where this isn’t working) is on AWS. We’re using an Amazon Aurora database, which may have something to do with this problem.

    The only other thing I know of that can sometimes produce this kind of issue is our admin menu plugin (Admin Menu Editor Pro), which we use to organize menus and access to menus. But this is setup in both environments. There’s no reason it would interfere in one environment and not the other, so I think this is an unlikely cause.

    If you have any further insights please let me know. I do need to get this fixed eventually…

    ~ Michael

    Plugin Author David Artiss

    (@dartiss)

    John,

    Okay, so that error is the answer – because you have caching in place this plugin won’t work for you.

    Michael,

    This is odd indeed. IF you had object caching in place it should report this. The URLs look how I’d expect them too.

    Basically, it’s not adding the menu when you activate the plugin and those reasons I gave before (which we’ve ruled out) are the only reason the plugin will (intentionally) do this.

    Have you tried the plugin on your production site, yet, to see if it works?

    Hi David,

    The problem is occurring only on the production site. In my local environment it actually works properly, and adds the menu as expected. It was this difference that prompted me to join the conversation here in the first place.

    I really have no idea why this would occur in my production environment, and not in the local. There are no errors or messages, other than the access notification I posted above. The plugin activates, but there is simply no menu item for it.

    If you think of anything that may be causing this please let me know, and I’ll test it.

    All my best,

    ~ Michael

    Just Updated the latest version and now I am getting message

    “Sorry, you are not allowed to access this page.”

Viewing 15 replies - 1 through 15 (of 22 total)
  • The topic ‘Sorry, You are not allowed to access this page.’ is closed to new replies.