Support » Fixing WordPress » Sorry, you are not allowed to access this page

  • Started a short while ago. Suspect around the time I updated WP. I have deactivated all plugins to no avail. Tried switching themes, no help there. And looked for database keys with he wrong prefix, but couldn’t find any.

    When logging in I am sent to a page showing the error message, but if I then delete the /wp-admin… part of the URL I get the toolbar at the top of the screen meaning I am actually logged in.

    I cannot access the updates page, and the dropdown with my site’s name on it does not work, but if I click the comments “button” I am taken to the admin page. The other buttons work as expected.

    Once there I can do most things, but I cannot access updates, or edit users.

    This is very frustrating. I have seen several posts about this, but none of the solutions put forward have worked.

    Best regards
    Geir Rosset
    Oslo
    Norway

Viewing 4 replies - 1 through 4 (of 4 total)
  • Thread Starter geirrosset

    (@geirrosset)

    Added info: When I am on the admin page the drop down with my site’s name in the top left works.

    Thread Starter geirrosset

    (@geirrosset)

    More info:

    Today I was successful in logging in. Did nothing differently. Took me to the home page. All other errors are still the same.

    Clicking “Updates” in the top menu gives me the “Sorry” error. I can however perform the updates if I do them through the Plugin or Theme pages.

    Activating Jetpack does not work. Clicking on Connect to WordPress.com gives me the “Sorry” error.

    I found your post from another thread so you can answer my questions from that one over here since you did start a topic of your own, which I didn’t realize at the time:

    @geirrosset Do you remember what the last thing you did was before you received this error? It’s a long shot since you mentioned this happened ages ago, but I thought I’d ask, anyway.

    – Did you backup, then reset your settings?
    – Did you have a security plugin installed before this issue first occurred?
    – Did you run any security scans to see if there were any issues?
    – Did you check your access logs when it first happened to check for unauthorized access to files or the database?
    – Did you check your file permissions to make sure they’re all set correctly?
    – When did this start happening? What version of WordPress and PHP did you have installed at that time?
    – Do you have any backups saved?
    – did you check your error log when it started happening?
    – Did you try turning on wp_debug with logging?
    – Did you check the _usermeta table for incorrect references to the prefix in the meta_key column?
    – Did you check the _options table for an incorrect reference in the option_name column and _user_roles?

    Trying to gather as much info as I can to see if I can figure something out for you.

    I know you said starting over wasn’t an option, but have you considered exporting your posts, media, users, etc. and importing them to a fresh site? It wouldn’t exactly be starting over from scratch. Just thought I’d throw it out there.

    It’s also a good idea to start a new thread as per the support forum guidelines, especially since all the fixes mentioned here haven’t resolved this for you.

    From this thread: https://wordpress.org/support/topic/wp-admin-sorry-you-are-not-allowed-to-access-this-page/

    P.S. You can ignore the questions that are answered already in this topic like the last thing you did and the version. Forgot to edit those out.

    Edit: For some reason, my last reply isn’t showing up so here’s what was basically said in case you also can’t see it:

    I found your topic through another topic you posted on after replying to you. I didn’t realize you already had a topic open at the time. You can reply here instead.

    @geirrosset Do you remember what the last thing you did was before you received this error? It’s a long shot since you mentioned this happened ages ago, but I thought I’d ask, anyway.

    – Did you backup, then reset your settings?
    – Did you have a security plugin installed before this issue first occurred?
    – Did you run any security scans to see if there were any issues?
    – Did you check your access logs when it first happened to check for unauthorized access to files or the database?
    – Did you check your file permissions to make sure they’re all set correctly?
    – When did this start happening? What version of WordPress and PHP did you have installed at that time?
    – Do you have any backups saved?
    – did you check your error log when it started happening?
    – Did you try turning on wp_debug with logging?
    – Did you check the _usermeta table for incorrect references to the prefix in the meta_key column?
    – Did you check the _options table for an incorrect reference in the option_name column and _user_roles?

    Trying to gather as much info as I can to see if I can figure something out for you.

    I know you said starting over wasn’t an option, but have you considered exporting your posts, media, users, etc. and importing them to a fresh site? It wouldn’t exactly be starting over from scratch. Just thought I’d throw it out there.

    It’s also a good idea to start a new thread as per the support forum guidelines, especially since all the fixes mentioned here haven’t resolved this for you.

    From thread: https://wordpress.org/support/topic/wp-admin-sorry-you-are-not-allowed-to-access-this-page/page/3/

    • This reply was modified 4 years, 8 months ago by Jenni McKinnon. Reason: Previous reply wasn't showing
Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Sorry, you are not allowed to access this page’ is closed to new replies.