Support » Plugin: WooCommerce Stripe Payment Gateway » Sorry, we are unable to process your payment at this time. Please retry later.

  • Resolved mdelegacz

    (@mdelegacz)


    Hello,

    When checking out on my website using Woocommerce Stripe Gateway I am getting an error

    Sorry, we are unable to process your payment at this time. Please retry later.

    My Stripe Dashboard is displaying 200OK with 100% Sucess Rate, WooCommerce reports transactions are Failed.

    So far I have done the following tests:
    – Run it on tests stripe keys
    – Run it on live stripe keys
    – Disable all plugins
    – Disable all plugins change the theme
    – Run setup wizard again
    – Connect Stripe account to the woocommerce dashboard to make sure keys match.
    – WordPress logs are not displaying any errors
    – Woocommerce logs seem empty

    I am running Woocommerce Storefront theme, all recommended plugins (Woocommerce MailChimp, Jetpack) + Revslider + WPBakery Visual Composer.
    I also have custom PHP code to check if users are logged in and redirect them to a login page if they are not when clicking on cart/checkout/shop pages. Disabling the code did not help in resolving the issue

    Thanks in advance

    The page I need help with: [log in to see the link]

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Support Mike W

    (@nixiack8)

    Hi @mdelegacz,

    This indeed sounds like an interesting issue! As you have tried several things, this may be something that the WooCommerce team may need to take a closer look at on the site itself. Due to this, please submit a ticket to us at this link.

    Be sure to add this information into it, and a copy of your WooCommerce Status Report, found under WooCommerce > Status. (There will be a button for Copy for Support). We will then be able to take a more in depth look and get this going for you!

    Also, if you like please put the ticket number (just the number, not a link) here after you have submitted it and I will be sure to pull it and get it going. I look forward to seeing it!

    @nixiack8 Ticket number: 1894621

    Thank you!

    Had the exact same issue on one of my sites. Please resolve it,.. in the meantime, I will try something else to integrate stripe onto my site

    My issue was resolved by the Support. Issue itself was caused by special characters in Statment notice such as TM glyph. Try to use plain Latin alphabet letters and see if that help @rexisrael7

Viewing 4 replies - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.